summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean@malleable.com>2008-06-28 21:28:16 +0000
committerSean Bright <sean@malleable.com>2008-06-28 21:28:16 +0000
commit19830f3359c6a6d9537b7c2d519ebaa663d091f6 (patch)
treeb02fc126725176a082a83e6b847de0e02b2b4eac /configure.ac
parentaf671ade7edf31c4827c3214613d4fe5a6a10e3a (diff)
Merge in changes from my cdr-tds-conversion branch. This changes the internal
implementation from using the volatile libtds, to using the db-lib front end. The unintended side effect of this is that we support (at least) versions 0.62 through 0.82 of the FreeTDS distribution without any #ifdef ugliness. (closes issue #12844) Reported by: jcollie git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@126226 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 1 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 847ccda0f..ecd0758b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1389,34 +1389,7 @@ fi
AST_EXT_TOOL_CHECK([GMIME], [gmime])
-AST_EXT_LIB_CHECK([FREETDS], [tds], [tds_version], [tds.h])
-if test "${PBX_FREETDS}" != "0";
-then
- if test "${FREETDS_DIR}x" = "x";
- then
- for tds_dir in /usr /usr/local;
- do
- if test -f "${tds_dir}/include/tdsver.h";
- then
- FREETDS_DIR="${tds_dir}"
- fi
- done
- fi
- case `${GREP} TDS_VERSION_NO ${FREETDS_DIR:-/usr}/include/tdsver.h` in
- *0.64*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_64"
- ;;
- *0.63*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_63"
- ;;
- *0.62*)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_0_62"
- ;;
- *)
- FREETDS_INCLUDE="${FREETDS_INCLUDE} -DFREETDS_PRE_0_62"
- ;;
- esac
-fi
+AST_EXT_LIB_CHECK([FREETDS], [sybdb], [dbinit], [sybdb.h])
AST_EXT_LIB_CHECK([TERMCAP], [termcap], [tgetent], [])