summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2018-04-26 19:09:16 -0500
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-04-26 19:09:16 -0500
commit2cef65dc777a24da6999c6bed21f896e8ab79507 (patch)
tree9a24cbc48483f26f66847d0d5018aab2b203f513 /configure.ac
parent8c1400bb57a434f2a1d36773fe98382355cb74b6 (diff)
parentfe072f440517cffd4cfb2b468b7424302a3ff9b6 (diff)
Merge "BuildSystem: Enable IMAP storage on FreeBSD and DragonFly BSD."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac60
1 files changed, 60 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 128b0a0f8..63991e556 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2039,6 +2039,66 @@ if test "${USE_IMAP_TK}" != "no"; then
[ac_cv_imap_tk="yes"],
[ac_cv_imap_tk="no"]
)
+ if test "${ac_cv_imap_tk}" = "no"; then
+ imap_libs="-lcrypto -lssl -lc-client4"
+ LIBS="${saved_libs} ${imap_libs} "`echo ${imap_ldflags}`
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <stdio.h>
+ #include <c-client/c-client.h>
+ void mm_searched (MAILSTREAM *stream,unsigned long number)
+ {
+ }
+ void mm_exists (MAILSTREAM *stream,unsigned long number)
+ {
+ }
+ void mm_expunged (MAILSTREAM *stream,unsigned long number)
+ {
+ }
+ void mm_flags (MAILSTREAM *stream,unsigned long number)
+ {
+ }
+ void mm_notify (MAILSTREAM *stream,char *string,long errflg)
+ {
+ }
+ void mm_list (MAILSTREAM *stream,int delimiter,char *mailbox,long attributes)
+ {
+ }
+ void mm_lsub (MAILSTREAM *stream,int delimiter,char *mailbox,long attributes)
+ {
+ }
+ void mm_status (MAILSTREAM *stream,char *mailbox,MAILSTATUS *status)
+ {
+ }
+ void mm_log (char *string,long errflg)
+ {
+ }
+ void mm_dlog (char *string)
+ {
+ }
+ void mm_login (NETMBX *mb,char *user,char *pwd,long trial)
+ {
+ }
+ void mm_critical (MAILSTREAM *stream)
+ {
+ }
+ void mm_nocritical (MAILSTREAM *stream)
+ {
+ }
+ long mm_diskerror (MAILSTREAM *stream,long errcode,long serious)
+ {
+ }
+ void mm_fatal (char *string)
+ {
+ }],
+ [
+ MAILSTREAM *foo = mail_open(NULL, "", 0);
+ ]
+ )],
+ [ac_cv_imap_tk="yes"],
+ [ac_cv_imap_tk="no"]
+ )
+ fi
if test "${ac_cv_imap_tk}" = "yes"; then
AC_LINK_IFELSE(
[AC_LANG_PROGRAM(