summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2006-08-25 00:13:03 +0000
committerRussell Bryant <russell@russellbryant.com>2006-08-25 00:13:03 +0000
commit5008225fcf3476929a5bcb49b06c9762deba2ec1 (patch)
tree86b2d29a2f56e70748bcf9b32df3fbc109a5c662 /configure.ac
parent310cb52bb48065bf029f67e69c83daf9b138c8af (diff)
get cflags for libcurl as well as libs (patch from qwell)
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@41023 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c3eacdc57..c166c081b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -917,20 +917,23 @@ if test ! x"${CURL}" = xNo; then
# check for version
if test "${host_os}" = "SunOS"; then
if [[ 0x`curl-config --vernum` -ge 0x70907 ]]; then
- CURLLIB=$(${CURL} --libs)
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
PBX_CURL=1
AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
fi
else
if [[[ 0x`curl-config --vernum` -ge 0x70907 ]]]; then
- CURLLIB=$(${CURL} --libs)
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
PBX_CURL=1
AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
fi
fi
fi
AC_SUBST(PBX_CURL)
-AC_SUBST(CURLLIB)
+AC_SUBST(CURL_INCLUDE)
+AC_SUBST(CURL_LIB)
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts])
AC_OUTPUT