summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2011-03-07 01:01:08 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2011-03-07 01:01:08 +0000
commit6de13322141d2750ee29f257558578782021edfe (patch)
treec25c45bb13a3a54ab23b610f15d8cbf6ae3140d3 /configure.ac
parent0a96892b04d4a07ec69040faa7cfd08ab2c22dd8 (diff)
Merged revisions 309808 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.8 ................ r309808 | tilghman | 2011-03-06 18:54:42 -0600 (Sun, 06 Mar 2011) | 14 lines Merged revisions 309251 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.6.2 ........ r309251 | tilghman | 2011-03-01 19:06:02 -0600 (Tue, 01 Mar 2011) | 7 lines Revert previous 2 commits, and instead conditionally redefine the same macro used in flex 2.5.35 that clashed with our workaround. Not surprisingly, the workaround was exactly the same code as was provided by the Flex maintainers, albeit in two different places, in different macros. This should fix the FreeBSD builds, which have an older version of Flex. ........ ................ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@309809 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 0 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 763cd1a22..9e8a2df81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,47 +301,6 @@ __EOL__
rm -rf ${tmp}
fi
])
-AC_CACHE_CHECK([for flex that ignores fwrite return value], [ac_cv_FLEX_WORKAROUND], [
- if test "x$FLEX" != "x:" ; then
- # Create a temporary directory $tmp in $TMPDIR (default /tmp).
- # Use mktemp if possible; otherwise fall back on mkdir,
- # with $RANDOM to make collisions less likely.
- : ${TMPDIR=/tmp}
- {
- tmp=`
- (umask 077 && mktemp -d "$TMPDIR/fooXXXXXX") 2>/dev/null
- ` &&
- test -n "$tmp" && test -d "$tmp"
- } || {
- tmp=$TMPDIR/foo$$-$RANDOM
- (umask 077 && mkdir "$tmp")
- } || exit $?
- cat >$tmp/test.fl <<__EOL__
-%{
-#include <unistd.h>
-#include <stdio.h>
-static void yyunput (int c,char *buf_ptr ) __attribute__((unused));
-static int input(void) __attribute__((unused));
-%}
-
-%%
-username printf( "%s", getlogin() );
-__EOL__
- ${FLEX} -o ${tmp}/test.c ${tmp}/test.fl
- ${CC} -o ${tmp}/test.o -c ${tmp}/test.c -Wall -Werror >/dev/null 2>&1
- if test -e "${tmp}/test.o"; then
- ac_cv_FLEX_WORKAROUND=no
- else
- ac_cv_FLEX_WORKAROUND=yes
- fi
- rm -rf ${tmp}
- fi
- ])
-
-if test "x${ac_cv_FLEX_WORKAROUND}" = "xyes"; then
- AC_DEFINE([NEED_FLEX_FWRITE_WORKAROUND], 1, [Define to 1 if your system has a version of flex that does not check the return value of fwrite.])
-fi
-
if test "x${ac_cv_path_BISON2}" = "x" ; then
BISON=:
PBX_BISON=0