summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2006-08-17 06:16:00 +0000
committerRussell Bryant <russell@russellbryant.com>2006-08-17 06:16:00 +0000
commit6ec6d652bde6ee2c00ad8e38a684ec6f690ec7e2 (patch)
tree32c364e4e9b83d82eb3ab1b372d977fff98eb11c /configure.ac
parent3409e55603fff0a7c40e1f724e0c40fa25def176 (diff)
print a warning at the end of the configure script if the version of GNU Make
in use is a version earlier than 3.81 This is for file :) git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@40153 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff1e02626..83cf0242a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -932,3 +932,13 @@ if test "x${crossCompile}" = xYes; then
AC_MSG_NOTICE( Cross Compilation = YES)
AC_MSG_NOTICE( Target = ${host})
fi
+
+if test ${GNU_MAKE_VERSION_MAJOR} -lt 3 || test ${GNU_MAKE_VERSION_MINOR} -lt 81 ; then
+ AC_MSG_NOTICE()
+ AC_MSG_NOTICE(***** WARNING ******)
+ AC_MSG_NOTICE(You are currently using GNU Make version ${GNU_MAKE_VERSION_MAJOR}.${GNU_MAKE_VERSION_MINOR}.)
+ AC_MSG_NOTICE(The Asterisk build system uses features that may not work correctly prior to 3.81.)
+ AC_MSG_NOTICE(Please consider upgrading GNU Make or you may experience problems.)
+ AC_MSG_NOTICE(********************)
+ AC_MSG_NOTICE()
+fi