summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Parker <jparker@digium.com>2007-07-10 18:41:03 +0000
committerJason Parker <jparker@digium.com>2007-07-10 18:41:03 +0000
commit8a5cea16bc9de4b12e04e6f9742db488415275b8 (patch)
tree0963557bfff27269a5efe726c81cbb8e5b494989 /configure.ac
parente9290d5178a30ac4947ccd28ea8cbd8c74ecb5cb (diff)
Merged revisions 74374 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 (closes issue #10133) ................ r74374 | qwell | 2007-07-10 13:39:30 -0500 (Tue, 10 Jul 2007) | 13 lines Merged revisions 74373 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.2 ........ r74373 | qwell | 2007-07-10 13:37:23 -0500 (Tue, 10 Jul 2007) | 5 lines Use res_ndestroy on systems that have it. Otherwise, use res_nclose. This prevents a memleak on NetBSD - and possibly others. Issue 10133, patch by me, reported and tested by scw ........ ................ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@74375 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4766e5608..081a5e35a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -351,7 +351,15 @@ AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <resolv.h>],
[int foo = res_ninit(NULL);]),
AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_RES_NINIT], 1, [Define to 1 if your system has the re-entrant resolver functions.]),
+ AC_DEFINE([HAVE_RES_NINIT], 1, [Define to 1 if your system has the re-entrant resolver functions.])
+ AC_MSG_CHECKING(for res_ndestroy)
+ AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([#include <resolv.h>],
+ [int foo = res_ndestroy(NULL);]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_RES_NDESTROY], 1, [Define to 1 if your system has the ndestroy resolver function.]),
+ AC_MSG_RESULT(no)
+ ),
AC_MSG_RESULT(no)
)