summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2007-01-08 03:56:06 +0000
committerKevin P. Fleming <kpfleming@digium.com>2007-01-08 03:56:06 +0000
commitecfc328d1a2083f343a82f7f53669fe637d75533 (patch)
tree4dcf9b5535dbee87103807eff987d7488622e78d /configure.ac
parent52ea03bd8652cd29f3616d4acbb0f5ae4ecb6a77 (diff)
Merged revisions 49866 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r49866 | kpfleming | 2007-01-07 21:53:53 -0600 (Sun, 07 Jan 2007) | 2 lines since we use AC_PATH_TOOL to find tools, we should use the results it provides for us (reported by Brian Capouch on the asterisk-dev list) ........ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@49870 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 59ac22402..598585d0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,7 +605,7 @@ if test "${USE_NETSNMP}" != "no"; then
fi
fi
if test x"${NETSNMP_CONFIG}" != xNo; then
- NETSNMP_libs=`net-snmp-config --agent-libs`
+ NETSNMP_libs=`${NETSNMP_CONFIG} --agent-libs`
AC_CHECK_LIB([netsnmp], [snmp_register_callback], AC_DEFINE_UNQUOTED([HAVE_NETSNMP], 1,
[Define to indicate the Net-SNMP library]), [], ${NETSNMP_libs})
@@ -646,8 +646,8 @@ if test "${USE_PGSQL}" != "no"; then
fi
fi
if test "${PG_CONFIG}" != No; then
- PGSQL_libdir=`pg_config --libdir`
- PGSQL_includedir=`pg_config --includedir`
+ PGSQL_libdir=`${PG_CONFIG} --libdir`
+ PGSQL_includedir=`${PG_CONFIG} --includedir`
AC_CHECK_LIB([pq], [PQexec], AC_DEFINE_UNQUOTED([HAVE_PGSQL], 1,
[Define to indicate the PostgreSQL library]), [], -L${PGSQL_libdir} -lz)
@@ -942,12 +942,12 @@ AC_SUBST(GTK_INCLUDE)
AC_SUBST(GTK_LIB)
if test "${USE_CURL}" != "no"; then
- AC_PATH_TOOL([CURL], [curl-config], No)
- if test ! x"${CURL}" = xNo; then
+ AC_PATH_TOOL([CURL_CONFIG], [curl-config], No)
+ if test ! x"${CURL_CONFIG}" = xNo; then
# check for version
- if test $(printf "%d" 0x$(curl-config --vernum)) -ge $(printf "%d" 0x070907); then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
+ if test $(printf "%d" 0x$(${CURL_CONFIG} --vernum)) -ge $(printf "%d" 0x070907); then
+ CURL_INCLUDE=$(${CURL_CONFIG} --cflags)
+ CURL_LIB=$(${CURL_CONFIG} --libs)
PBX_CURL=1
AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
fi