summaryrefslogtreecommitdiff
path: root/menuselect/configure.ac
diff options
context:
space:
mode:
authorMatthew Jordan <mjordan@digium.com>2014-07-17 19:02:22 +0000
committerMatthew Jordan <mjordan@digium.com>2014-07-17 19:02:22 +0000
commit26c7e684eaffe2c7f08219984147b23f66c7dca5 (patch)
treea52a5e9c8304aaa182d5ee194110aa45bdc3057b /menuselect/configure.ac
parent62f5e26d354f49a7359bc242c1dd1a9661175b09 (diff)
menuselect: Add libxml2 support (Patch 3)
This is the final patch in adding menuselect to Asterisk. - The first patch (r418832) added menuselect along with mxml - The second patch (r418833) removed mxml from menuselect This patch adds support for libxml2 to menuselect, and makes libxml2 a required library for Asterisk. Note that the libxml2 portion of this patch was written by Sean Bright, and was made available on a team branch: http://svn.digium.com/svn/menuselect/team/seanbright/libxml2/ Review: https://reviewboard.asterisk.org/r/3773/ ASTERISK-20703 #close patches: some_mysterious_team_branch uploaded by seanbright (License 5060) git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@418834 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'menuselect/configure.ac')
-rw-r--r--menuselect/configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/menuselect/configure.ac b/menuselect/configure.ac
index 5ebcaaa49..516d19eb5 100644
--- a/menuselect/configure.ac
+++ b/menuselect/configure.ac
@@ -120,10 +120,19 @@ AC_CHECK_FUNCS([asprintf getloadavg setenv strcasestr strndup strnlen strsep uns
AST_EXT_LIB_SETUP([NEWT], [newt], [newt])
AST_EXT_LIB_SETUP([CURSES], [curses], [curses])
AST_EXT_LIB_SETUP([NCURSES], [ncurses], [ncurses])
+AST_EXT_LIB_SETUP([LIBXML2], [LibXML2], [libxml2])
AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
AST_EXT_LIB_CHECK([NCURSES], [ncurses], [initscr], [curses.h])
+AST_EXT_TOOL_CHECK([LIBXML2], [xml2-config], , ,
+ [#include <libxml/tree.h>
+ #include <libxml/parser.h>],
+ [LIBXML_TEST_VERSION])
+
+if test "${PBX_LIBXML2}" != 1; then
+ AC_MSG_ERROR([coult not find required 'Libxml2' development package])
+fi
PBX_GTK2=0
AC_CHECK_TOOL(PKGCONFIG, pkg-config, No)
@@ -140,7 +149,6 @@ AC_SUBST(GTK2_LIB)
test "$silent"=yes && ac_sub_configure_args="${ac_sub_configure_args} --silent"
AC_CONFIG_FILES([makeopts])
-AC_CONFIG_SUBDIRS([mxml])
AC_OUTPUT
AC_MSG_NOTICE(Menuselect build configuration successfully completed)