summaryrefslogtreecommitdiff
path: root/menuselect/configure.ac
diff options
context:
space:
mode:
authorAlexander Traud <pabstraud@compuserve.com>2018-04-20 12:40:21 +0200
committerAlexander Traud <pabstraud@compuserve.com>2018-04-20 12:44:12 +0200
commitd54637373ab890b9e8b239290a241ca821058077 (patch)
treecff82e54e62bbde618874f50abe4b1a6bec47f76 /menuselect/configure.ac
parenta9c74fdc0462349bd9ae6f25ae72f071c95d1e76 (diff)
menuselect: Add DragonFly BSD.
In DragonFly BSD, added libraries from ports are placed into /usr/local. Therefore, this directory must be added for the preprocessor, compiler, and linker. Beside that, the script ./configure was updated: * OSARCH list was outdated and not used, removed. * AC_CANONICAL_BUILD was not used. * _REENTRANT, this feature test macro is obsolete. ASTERISK-27820 Change-Id: I186d88d99cfa4de6569888e12ac97bd2f441c422
Diffstat (limited to 'menuselect/configure.ac')
-rw-r--r--menuselect/configure.ac40
1 files changed, 9 insertions, 31 deletions
diff --git a/menuselect/configure.ac b/menuselect/configure.ac
index 2dd4ed652..4a2d0acc2 100644
--- a/menuselect/configure.ac
+++ b/menuselect/configure.ac
@@ -1,5 +1,3 @@
-# Process this file with autoconf to produce a configure script.
-
AC_PREREQ(2.59)
m4_define([MENUSELECT_VERSION],
@@ -16,49 +14,29 @@ AC_CONFIG_HEADER(autoconfig.h)
AC_COPYRIGHT("Menuselect")
-AC_CANONICAL_BUILD
AC_CANONICAL_HOST
HOST_OS=${host_os}
AC_SUBST(HOST_OS)
-PBX_WINARCH=0
case "${host_os}" in
- freebsd*)
- OSARCH=FreeBSD
- ;;
- netbsd*)
- OSARCH=NetBSD
- ;;
- openbsd*)
- OSARCH=OpenBSD
- ;;
- solaris*)
- OSARCH=SunOS
+ *dragonfly*)
+ CPPFLAGS="${CPPFLAGS} -I/usr/local/include"
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
;;
- mingw32)
- OSARCH=mingw32
- PBX_WINARCH=1
+ *netbsd*)
+ CPPFLAGS="${CPPFLAGS} -I/usr/pkg/include"
+ LDFLAGS="${LDFLAGS} -L/usr/pkg/lib"
;;
- cygwin)
- OSARCH=cygwin
- PBX_WINARCH=1
- ;;
- linux-gnueabi)
- OSARCH=linux-gnu
- ;;
- *)
- OSARCH=${host_os}
+ *bsd*)
+ CPPFLAGS="${CPPFLAGS} -I/usr/local/include"
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
;;
esac
AH_TOP(
#ifndef MENUSELECT_AUTOCONFIG_H
#define MENUSELECT_AUTOCONFIG_H
-
-#ifndef _REENTRANT
-#define _REENTRANT
-#endif
)
AH_BOTTOM([#endif])