summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6c066802..71ef55486 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,17 @@ AC_SUBST(HOST_CPU)
AC_SUBST(HOST_VENDOR)
AC_SUBST(HOST_OS)
+case "${host_os}" in
+ freebsd*)
+ OSARCH=FreeBSD
+ ;;
+ *)
+ OSARCH=${HOST_OS}
+ ;;
+esac
+
+AC_SUBST(OSARCH)
+
# check for uname
AC_PATH_TOOL([UNAME], [uname], No)
if test ! x"${UNAME}" = xNo; then