summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a56fbecc..aa8966802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,10 @@ AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent ftruncate getcwd gethostbyna
AC_CHECK_FUNCS([glob])
AC_CHECK_FUNCS([timersub])
-AC_CHECK_HEADER([sys/poll.h], [HAS_POLL=1],)
+AC_CHECK_HEADER([sys/poll.h],
+ [HAS_POLL=1]
+ AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),
+ )
AC_SUBST(HAS_POLL)
# https support (in main/http.c) uses funopen on BSD systems,