summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2008-05-26 12:31:34 +0000
committerKevin P. Fleming <kpfleming@digium.com>2008-05-26 12:31:34 +0000
commit439a071297f20bba76caa63fca18f628d76bf139 (patch)
treeaedf58ec07cd9ad3202ea21adc18e0deff3caf81 /configure.ac
parentae83d21858dc68cadc6ca0d86f260b88ed1ebfd6 (diff)
update acinclude.m4 to match the one in Asterisk trunk, rebuild checks for libraries, and add mandatory check for DAHDI
git-svn-id: http://svn.asterisk.org/svn/dahdi/tools/trunk@4361 a0bf4364-ded3-4de4-8d8a-66a801d63aff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 20 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index fbf6e7a..1ac41e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,10 +63,17 @@ AC_SUBST(DOWNLOAD)
AC_LANG(C)
-AST_EXT_LIB([curses], [initscr], [curses.h], [CURSES], [curses], [])
-AST_EXT_LIB([ncurses], [initscr], [curses.h], [NCURSES], [ncurses], [])
-AST_EXT_LIB([newt], [newtBell], [newt.h], [NEWT], [newt])
-AST_EXT_LIB([usb], [usb_init], [usb.h], [USB], [libusb])
+AST_EXT_LIB_SETUP([CURSES], [curses], [curses])
+AST_EXT_LIB_SETUP([DAHDI], [DAHDI], [dahdi])
+AST_EXT_LIB_SETUP([NCURSES], [ncurses], [ncurses])
+AST_EXT_LIB_SETUP([NEWT], [newt], [newt])
+AST_EXT_LIB_SETUP([USB], [usb], [usb])
+
+AST_EXT_LIB_CHECK([CURSES], [curses], [initscr], [curses.h])
+AST_C_DEFINE_CHECK([DAHDI], [DAHDI_CODE], [dahdi/user.h])
+AST_EXT_LIB_CHECK([NCURSES], [ncurses], [initscr], [curses.h])
+AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
+AST_EXT_LIB_CHECK([USB], [libusb], [usb_init], [usb.h])
AC_ARG_WITH(selinux,
[AS_HELP_STRING([--with-selinux],
@@ -92,7 +99,7 @@ fi
AC_SUBST(ASCIIDOC)
AC_ARG_WITH(ppp,
- [AS_HELP_STRING([--with-ppp=PATH],[Use ppp support from PATH])],
+ [AS_HELP_STRING([--with-ppp=PATH],[Use PPP support from PATH])],
[],
[with_ppp=check]
)
@@ -122,10 +129,17 @@ case "$with_ppp" in
;;
esac
+if test "x${PBX_DAHDI}" != "x1"; then
+ AC_MSG_NOTICE([***])
+ AC_MSG_NOTICE([*** Building this package requires DAHDI support. *** ])
+ AC_MSG_NOTICE([*** Please install the dahdi-linux package. ***])
+ AC_MSG_NOTICE([***])
+ exit 1
+fi
+
AC_SUBST(PPPD_VERSION)
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts])
AC_OUTPUT
AC_MSG_NOTICE(*** dahdi-tools build successfully configured ***)
-