summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean@malleable.com>2009-09-15 19:55:29 +0000
committerSean Bright <sean@malleable.com>2009-09-15 19:55:29 +0000
commit670e01a3f9558e7d2ee77e020ac174d6cd146e9b (patch)
tree0e59cdee38cd1fd35f005ed15eed82353cbed95c /configure.ac
parente26ea2f072a3702efcd1a3ee93ed58ab049977d5 (diff)
Use configure to determine the location of header files instead of relying on
the platform. Still need to copy bootstrap.sh from asterisk and tonezone.c still needs to be updated appropriately. git-svn-id: http://svn.asterisk.org/svn/dahdi/tools/trunk@7137 a0bf4364-ded3-4de4-8d8a-66a801d63aff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8893fec..9c755af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,9 +26,14 @@ if test ${localstatedir} = '${prefix}/var'; then
localstatedir=/var
fi
+# specify output header file
+AC_CONFIG_HEADER(autoconfig.h)
+
# This needs to be before any macros that use the C compiler
AC_GNU_SOURCE
+AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h])
+
# Checks for programs.
AC_PROG_CC
AC_PROG_CPP