summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean@malleable.com>2008-09-24 19:54:08 +0000
committerSean Bright <sean@malleable.com>2008-09-24 19:54:08 +0000
commit8016f6f88001547955c95171a2200739f5d9d081 (patch)
treee47a60bf8d1d2a084504c07212e6e70266641e13 /configure.ac
parent36fc7cab7efa13bb7dbeb80c642baf2b376284e3 (diff)
Re-enable sethdlc by default in menuselect. Add configure checks to properly
discover the linux/hdlc.h dependency. git-svn-id: http://svn.asterisk.org/svn/dahdi/tools/trunk@4977 a0bf4364-ded3-4de4-8d8a-66a801d63aff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 450d5c1..23929f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,8 @@ AST_C_DEFINE_CHECK([DAHDI], [DAHDI_CODE], [dahdi/user.h])
AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
AST_EXT_LIB_CHECK([USB], [usb], [usb_init], [usb.h])
+AST_C_DEFINE_CHECK([HDLC], [GENERIC_HDLC_VERSION], [linux/hdlc.h], [4])
+
AC_ARG_WITH(selinux,
[AS_HELP_STRING([--with-selinux],
[enable (with) / disable (without) SELinux])],
@@ -144,6 +146,16 @@ case "$with_ppp" in
;;
esac
+if test "x${PBX_HDLC}" == "x1"; then
+ AC_EGREP_CPP([VERSION = 4],
+ [#include <linux/hdlc.h>
+ VERSION = GENERIC_HDLC_VERSION], [], [PBX_HDLC=0])
+fi
+
+if test "x${PBX_HDLC}" != "x1"; then
+ AC_MSG_NOTICE([GENERIC_HDLC_VERSION version 4 not found, disabling sethdlc.])
+fi
+
if test "x${PBX_DAHDI}" != "x1"; then
AC_MSG_NOTICE([***])
AC_MSG_NOTICE([*** Building this package requires DAHDI support. *** ])