summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTzafrir Cohen <tzafrir.cohen@xorcom.com>2010-03-07 14:46:33 +0000
committerTzafrir Cohen <tzafrir.cohen@xorcom.com>2010-03-07 14:46:33 +0000
commitcf3104b829923df22271f85bb658e808baa8a657 (patch)
tree6d2a76eb3372dda7cebdb8c49f9096b4351b8846 /configure.ac
parente0b3ad722c4a760408ba97dc6a71eb9e183843e4 (diff)
dahdi-tools 2.3 requires dahdi-linux 2.3
If you try building dahdi-tools vs. older dahdi-linux headers, dahdi_cfg fails to build due to missing DAHDI_CONFIG_TERN and DAHDI_CONFIG_NTTE. git-svn-id: http://svn.asterisk.org/svn/dahdi/tools/trunk@8266 a0bf4364-ded3-4de4-8d8a-66a801d63aff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d1ea2a2..35e51e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,6 +94,8 @@ AST_EXT_LIB_SETUP([NEWT], [newt], [newt])
AST_EXT_LIB_SETUP([USB], [usb], [usb])
AST_C_DEFINE_CHECK([DAHDI], [DAHDI_CODE], [dahdi/user.h])
+DAHDI23_DIR="${DAHDI_DIR}"
+AST_C_DEFINE_CHECK([DAHDI23], [DAHDI_CONFIG_NTTE], [dahdi/user.h])
AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
AST_EXT_LIB_CHECK([USB], [usb], [usb_init], [usb.h])
@@ -197,6 +199,14 @@ if test "x${PBX_DAHDI}" != "x1"; then
exit 1
fi
+if test "x${PBX_DAHDI23}" != "x1"; then
+ AC_MSG_NOTICE([***])
+ AC_MSG_NOTICE([*** Building this package requires DAHDI support (>= 2.3) *** ])
+ AC_MSG_NOTICE([*** Please install a recent dahdi-linux package. ***])
+ AC_MSG_NOTICE([***])
+ exit 1
+fi
+
AC_SUBST(PPPD_VERSION)
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts])