summaryrefslogtreecommitdiff
path: root/orkbasecxx/Makefile.am
diff options
context:
space:
mode:
authorGerald Begumisa <ben_g@users.sourceforge.net>2007-12-20 02:53:14 +0000
committerGerald Begumisa <ben_g@users.sourceforge.net>2007-12-20 02:53:14 +0000
commit0e9d7cb80716bd22e0e5234af0a7d3ba4d5a3091 (patch)
treec37832192a74edd2c0805cfd6b6e33d054ef1e23 /orkbasecxx/Makefile.am
parentb4f73de93002e79ccdf6ee62cd91a533c0f7ba1f (diff)
Added a new feature that allows orkaudio to filter recordings by the remote or local party. If the configuration parameter <PartyFilter> is filled with a CSV list of numbers or ranges of numbers such as <PartyFilter>300,450-490,4000-6000</PartyFilter>, orkaudio will only produce recordings for cases where the remote or local parties match a specified number or fall within the specified number range (for the case where a range has been specified).
git-svn-id: https://oreka.svn.sourceforge.net/svnroot/oreka/trunk@516 09dcff7a-b715-0410-9601-b79a96267cd0
Diffstat (limited to 'orkbasecxx/Makefile.am')
-rw-r--r--orkbasecxx/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/orkbasecxx/Makefile.am b/orkbasecxx/Makefile.am
index f9aadf5..3bcd0ad 100644
--- a/orkbasecxx/Makefile.am
+++ b/orkbasecxx/Makefile.am
@@ -14,7 +14,8 @@ liborkbase_la_SOURCES = Filter.cpp g711.c \
MemUtils.cpp BatchProcessing.cpp \
CapturePluginProxy.cpp CapturePort.cpp \
Daemon.cpp ImmediateProcessing.cpp \
- Reporting.cpp TapeFileNaming.cpp
+ Reporting.cpp TapeFileNaming.cpp \
+ PartyFilter.cpp
#INCLUDES = -I/projects/ext/xmlrpc++/xmlrpc++0.7/src
SUBDIRS = messages serializers audiofile filters
liborkbase_la_LIBADD = $(top_builddir)/serializers/libserializers.la \