summaryrefslogtreecommitdiff
path: root/orkbasecxx/Makefile.am
diff options
context:
space:
mode:
authorGerald Begumisa <ben_g@users.sourceforge.net>2008-12-18 08:07:04 +0000
committerGerald Begumisa <ben_g@users.sourceforge.net>2008-12-18 08:07:04 +0000
commit3f5c1d9c9358eb6d7a1f2c75b49446303157fcd4 (patch)
tree8bce4fff04918d60ed8bed2669f9c21220556d80 /orkbasecxx/Makefile.am
parent960e134a00df44a2cb3eda87f2d7dcde9fb5156e (diff)
Added AudioGain filter that allows gain to be increased or reduced on all channels or a per-channel basis. Therefore 3 configuration parameters have been added, which are AudioGain, AudioGainChannel1 and AudioGainChannel2. These parameters take values in Db. Setting the AudioGain applies the gain to both channels. While setting AudioGainChannel1 and AudioGainChannel2 applies gain to channel 1 and channel 2 respectively.
git-svn-id: https://oreka.svn.sourceforge.net/svnroot/oreka/trunk@587 09dcff7a-b715-0410-9601-b79a96267cd0
Diffstat (limited to 'orkbasecxx/Makefile.am')
-rw-r--r--orkbasecxx/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/orkbasecxx/Makefile.am b/orkbasecxx/Makefile.am
index 3bcd0ad..3f30d49 100644
--- a/orkbasecxx/Makefile.am
+++ b/orkbasecxx/Makefile.am
@@ -24,6 +24,8 @@ liborkbase_la_LIBADD = $(top_builddir)/serializers/libserializers.la \
$(top_builddir)/filters/gsm/libgsm.la \
$(top_builddir)/filters/gsm/gsm610/libgsm610.la \
$(top_builddir)/filters/ilbc/libilbc.la \
- $(top_builddir)/filters/ilbc/ilbc/libilbcrfc.la
+ $(top_builddir)/filters/ilbc/ilbc/libilbcrfc.la \
+ $(top_builddir)/filters/audiogain/libaudiogain.la \
+ -lm
AM_CXXFLAGS = -D_REENTRANT