summaryrefslogtreecommitdiff
path: root/php-cpp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cpp.spec')
-rw-r--r--php-cpp.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/php-cpp.spec b/php-cpp.spec
new file mode 100644
index 0000000..af7d27d
--- /dev/null
+++ b/php-cpp.spec
@@ -0,0 +1,76 @@
+Summary: C++ library for developing PHP extensions
+Name: php-cpp
+Version: 1.5.3
+Release: 1
+License: Apache-2.0
+Group: Utilities/System
+Source: %{name}-%{version}.tar.gz
+# Patches auto-generated by git-buildpackage:
+Patch0:0001-Makefile-install-DESTDIR-and-more.patch
+Patch1:0002-Don-t-run-ldconfig-on-install.patch
+URL: https://github.com/CopernicaMarketingSoftware/PHP-CPP
+Vendor: Xorcom Inc
+Packager: Tzafrir Cohen <tzafrir.cohen@xorcom.com>
+Requires: php
+BuildRequires: php-devel
+
+%description
+The PHP-CPP library is a C++ library for developing PHP extensions. It
+offers a collection of well documented and easy-to-use classes that can
+be used and extended to build native extensions for PHP. The full
+documentation can be found on http://www.php-cpp.com.
+
+%package devel
+Summary: C++ library for developing PHP extensions - development headers
+%description devel
+The PHP-CPP library is a C++ library for developing PHP extensions. It
+offers a collection of well documented and easy-to-use classes that can
+be used and extended to build native extensions for PHP. The full
+documentation can be found on http://www.php-cpp.com.
+
+This package includes development headers.
+
+%prep
+%setup
+# 0001-Makefile-install-DESTDIR-and-more.patch
+%patch0 -p1
+# 0002-Don-t-run-ldconfig-on-install.patch
+%patch1 -p1
+
+%build
+%{__make}
+
+%install
+%{__rm} -rf %{buildroot}
+%make_install INSTALL_LIB=%{_libdir}
+
+%post
+/sbin/ldconfig
+
+%postun
+/sbin/ldconfig
+
+%clean
+%{__rm} -rf %{buildroot}
+
+###################################################################
+#
+# File List
+#
+###################################################################
+%files
+%defattr(-, root, root)
+%{_libdir}/libphpcpp.so.*
+%doc README.md
+
+%files devel
+%{_includedir}/phpcpp.h
+%{_includedir}/phpcpp/*
+%{_libdir}/libphpcpp.a*
+%{_libdir}/libphpcpp.so
+%doc Examples/*
+%doc documentation/*
+
+%changelog
+* Thu May 15 2016 tzafrir <tzafrir.cohen@xorcom.com> 1.5.3-1
+- Initial packaging.