summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAlex Landau <alex.landau@xorcom.com>2008-12-28 08:55:04 +0000
committerAlex Landau <alex.landau@xorcom.com>2008-12-28 08:55:04 +0000
commit94e268f4d359d6d2de417f991b8ea6f420d60d58 (patch)
treed0f4b90f8b72fb198d14ea976523a5519f118f8e /debian
parentbfcceffc9b62841da0d48a87aeceead870a5092c (diff)
rapid-tunneling:
- deb support (not tested, probably not working) git-svn-id: svn+ssh://xorcom/home/svn/debs/components/rapid-tunneling@6500 283159da-0705-0410-b60c-f2062b4bb6ad
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control25
-rw-r--r--debian/copyright38
-rw-r--r--debian/dirs2
-rw-r--r--debian/postinst43
-rw-r--r--debian/prerm41
-rwxr-xr-xdebian/rules18
8 files changed, 174 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..31b2930
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+rapid-tunneling (1.0-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Alex Landau <alex.landau@xorcom.com> Sun, 14 Dec 2008 17:20:04 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f9a165e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,25 @@
+Source: rapid-tunneling
+Section: net
+Priority: extra
+Maintainer: Alex Landau <alex.landau@xorcom.com>
+Build-Depends: cdbs, debhelper (>= 7)
+Standards-Version: 3.8.0
+Homepage: http://www.xorcom.com/
+
+Package: rapid-tunneling
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends} openssh-client
+Description: RapidTunneling (tm) client
+ RapidTunneling (tm) allows remote access to machines behind firewalls
+ and NAT routers via SSH port forwarding.
+ .
+ This package contains the client-side scripts.
+
+Package: rapid-tunneling-server
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends} openssh-server
+Description: RapidTunneling (tm) server
+ RapidTunneling (tm) allows remote access to machines behind firewalls
+ and NAT routers via SSH port forwarding.
+ .
+ This package contains the server-side scripts.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..58250d1
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,38 @@
+This package was debianized by Alex Landau <alex@unknown> on
+Sun, 14 Dec 2008 17:20:04 +0200.
+
+It was downloaded from <url://example.com>
+
+Upstream Author(s):
+
+ Alex Landau <alex.landau@xorcom.com>
+
+Copyright:
+
+ Copyright (C) 2008 Alex Landau
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is (C) 2008, Alex Landau <alex.landau@xorcom.com> and
+is licensed under the GPL, see above.
+
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..25fde56
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,43 @@
+#!/bin/sh
+# postinst script for rapid-tunneling
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ # add a user with uid=gid=0
+ useradd -d /var/lib/rapid-tunneling/home -m -u 0 -g 0 -o rapid-tunneling 2>/dev/null || true
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 0000000..7602eac
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,41 @@
+#!/bin/sh
+# prerm script for rapid-tunneling
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <prerm> `remove'
+# * <old-prerm> `upgrade' <new-version>
+# * <new-prerm> `failed-upgrade' <old-version>
+# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
+# * <deconfigured's-prerm> `deconfigure' `in-favour'
+# <package-being-installed> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ remove)
+ userdel -r rapid-tunneling || :
+ ;;
+
+ failed-upgrade)
+ ;;
+
+ *)
+ echo "prerm called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ab0251a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/makefile.mk
+
+DEB_MAKE_BUILD_TARGET = dummy
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
+
+clean::
+ rm -f debian/rapid-tunneling-server.ssh_support.init
+
+build/rapid-tunneling-server::
+ cp sshd_support_debian debian/rapid-tunneling-server.ssh_support.init
+
+install/rapid-tunneling-server::
+ dh_installinit -p rapid-tunneling-server --name=ssh_support
+