summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTzafrir Cohen <tzafrir.cohen@xorcom.com>2009-01-05 19:42:10 +0000
committerTzafrir Cohen <tzafrir.cohen@xorcom.com>2009-01-05 19:42:10 +0000
commitf6c6fd27a4634464f7ace0c135699cce02c43817 (patch)
tree5b1903b655ad21ad6144436257ae272066f092ea /debian
parentd7b80cace5be8b0e263cec1e36f0553842a6e991 (diff)
GPG signature of tarball; path changes
* The tarball sent by the support user is now signed: an extra sig.asc gpg ascii-armoured signature of the contents of all the other file (alphabetical order). * Client verifies that before touching the data further. * Hence packages depend on gnupg. * Error code from gpg errors: 7. * Scripts used by the server are now in /usr/share/rapid-tunneling/bin . * Server support user sources /usr/share/rapid-tunneling/support_env . * Fixed purging for Debian -server package. * rtadm's config file is /etc/rapid-tunneling/rtadm . git-svn-id: svn+ssh://xorcom/home/svn/debs/components/rapid-tunneling@6550 283159da-0705-0410-b60c-f2062b4bb6ad
Diffstat (limited to 'debian')
-rw-r--r--debian/control5
-rw-r--r--debian/dirs2
-rw-r--r--debian/rapid-tunneling-server.install7
-rw-r--r--debian/rapid-tunneling-server.postinst15
-rwxr-xr-xdebian/rapid-tunneling-server.postrm18
-rw-r--r--debian/rapid-tunneling-server.prerm44
-rw-r--r--debian/rapid-tunneling.install1
-rw-r--r--debian/rapid-tunneling.postinst (renamed from debian/postinst)0
8 files changed, 36 insertions, 56 deletions
diff --git a/debian/control b/debian/control
index f9a165e..5ebd1b2 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,14 @@ Source: rapid-tunneling
Section: net
Priority: extra
Maintainer: Alex Landau <alex.landau@xorcom.com>
+Uploaders: Tzafrir Cohen <tzafrir.cohen@xorcom.com>
Build-Depends: cdbs, debhelper (>= 7)
Standards-Version: 3.8.0
Homepage: http://www.xorcom.com/
Package: rapid-tunneling
Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends} openssh-client
+Depends: ${misc:Depends}, openssh-client, gnupg
Description: RapidTunneling (tm) client
RapidTunneling (tm) allows remote access to machines behind firewalls
and NAT routers via SSH port forwarding.
@@ -17,7 +18,7 @@ Description: RapidTunneling (tm) client
Package: rapid-tunneling-server
Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends} openssh-server
+Depends: ${misc:Depends}, openssh-server, gnupg, adduser
Description: RapidTunneling (tm) server
RapidTunneling (tm) allows remote access to machines behind firewalls
and NAT routers via SSH port forwarding.
diff --git a/debian/dirs b/debian/dirs
deleted file mode 100644
index ca882bb..0000000
--- a/debian/dirs
+++ /dev/null
@@ -1,2 +0,0 @@
-usr/bin
-usr/sbin
diff --git a/debian/rapid-tunneling-server.install b/debian/rapid-tunneling-server.install
index 035481c..e427762 100644
--- a/debian/rapid-tunneling-server.install
+++ b/debian/rapid-tunneling-server.install
@@ -1,4 +1,5 @@
-etc/default/rtadm
+etc/rapid-tunneling/rtadm
etc/ssh/sshd_support_config
-usr/sbin/rtadm
-usr/sbin/rt-from-remote
+usr/share/rapid-tunneling/support_env
+usr/share/rapid-tunneling/bin/rtadm
+usr/share/rapid-tunneling/bin/rt-from-remote
diff --git a/debian/rapid-tunneling-server.postinst b/debian/rapid-tunneling-server.postinst
index 18e8b5b..1a1c3fb 100644
--- a/debian/rapid-tunneling-server.postinst
+++ b/debian/rapid-tunneling-server.postinst
@@ -17,13 +17,20 @@ set -e
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
+HOME_DIR=/var/lib/rapid-tunneling/support
+NEW_USER=support
case "$1" in
configure)
- useradd -d /var/lib/rapid-tunneling-server -m support 2>/dev/null || :
- LINE='export PATH=$PATH:/usr/sbin'
- PROFILE=/var/lib/rapid-tunneling-server/.bash_profile
- if ! fgrep -q "$LINE" $PROFILE 2>/dev/null; then echo "$LINE" >> $PROFILE; fi
+ if ! getent passwd $NEW_USER >/dev/null; then
+ adduser --disabled-password --home $HOME_DIR \
+ --gecos "Rapid Tunneling support" $NEW_USER 2>/dev/null || :
+ fi
+ LINE='. /usr/share/rapid-tunneling/support_env'
+ PROFILE=$HOME_DIR/.profile
+ if ! fgrep -q "$LINE" $PROFILE 2>/dev/null; then
+ echo "$LINE" >> $PROFILE;
+ fi
;;
abort-upgrade|abort-remove|abort-deconfigure)
diff --git a/debian/rapid-tunneling-server.postrm b/debian/rapid-tunneling-server.postrm
new file mode 100755
index 0000000..0cd1583
--- /dev/null
+++ b/debian/rapid-tunneling-server.postrm
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+HOME_DIR=/var/lib/rapid-tunneling/support
+NEW_USER=support
+
+set -e
+
+case "$1" in
+ purge)
+ rm -rf $HOME_DIR
+ # Do we really need to?
+ userdel $NEW_USER || :
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rapid-tunneling-server.prerm b/debian/rapid-tunneling-server.prerm
deleted file mode 100644
index bd3bd15..0000000
--- a/debian/rapid-tunneling-server.prerm
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-# prerm script for rapid-tunneling
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <prerm> `remove'
-# * <old-prerm> `upgrade' <new-version>
-# * <new-prerm> `failed-upgrade' <old-version>
-# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
-# * <deconfigured's-prerm> `deconfigure' `in-favour'
-# <package-being-installed> <version> `removing'
-# <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- remove)
- userdel support || :
- ;;
-
- upgrade)
- ;;
-
- failed-upgrade)
- ;;
-
- *)
- echo "prerm called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
-
-
diff --git a/debian/rapid-tunneling.install b/debian/rapid-tunneling.install
index 9afcc19..ca4453e 100644
--- a/debian/rapid-tunneling.install
+++ b/debian/rapid-tunneling.install
@@ -1,4 +1,3 @@
usr/sbin/rapid-tunneling
usr/sbin/rapid-tunneling-status
-var/lib/rapid-tunneling
diff --git a/debian/postinst b/debian/rapid-tunneling.postinst
index 5fdc023..5fdc023 100644
--- a/debian/postinst
+++ b/debian/rapid-tunneling.postinst