summaryrefslogtreecommitdiff
path: root/rapid-tunneling.spec
diff options
context:
space:
mode:
authorAlex Landau <alex.landau@xorcom.com>2009-02-01 18:09:40 +0000
committerAlex Landau <alex.landau@xorcom.com>2009-02-01 18:09:40 +0000
commit8e13d7e1fddc0e7faaae5ac640a5e05b114eea33 (patch)
tree83a3dc0bacf985de73f732db9d06530e2b57f40a /rapid-tunneling.spec
parent743a1a366401973b9d5d823b2addeb61d2e698ab (diff)
rapid-tunneling:
- Added GUI password protection. - Backed out GPG. git-svn-id: svn+ssh://xorcom/home/svn/debs/components/rapid-tunneling@6682 283159da-0705-0410-b60c-f2062b4bb6ad
Diffstat (limited to 'rapid-tunneling.spec')
-rw-r--r--rapid-tunneling.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/rapid-tunneling.spec b/rapid-tunneling.spec
index 49811b5..d96b336 100644
--- a/rapid-tunneling.spec
+++ b/rapid-tunneling.spec
@@ -60,10 +60,14 @@ if [ "$1" = 0 ]; then
fi
%post server
-useradd -d /var/lib/rapid-tunneling-server -m support 2>/dev/null || :
-LINE='export PATH=$PATH:/usr/sbin'
-PROFILE=/var/lib/rapid-tunneling-server/.bash_profile
-if ! fgrep -q "$LINE" $PROFILE 2>/dev/null; then echo "$LINE" >> $PROFILE; fi
+HOME_DIR=/var/lib/rapid-tunneling/support
+NEW_USER=support
+useradd -d $HOME_DIR -m $NEW_USER 2>/dev/null || :
+LINE='. /usr/share/rapid-tunneling/support_env'
+PROFILE=$HOME_DIR/.bash_profile
+if ! fgrep -q "$LINE" $PROFILE 2>/dev/null; then
+ echo "$LINE" >> $PROFILE
+fi
/sbin/chkconfig --add sshd_support
%preun server
@@ -110,7 +114,12 @@ fi
%files gui
%defattr(-, root, root, 0755)
%{webroot}/
+%config(noreplace) /etc/rapid-tunneling/gui.htpasswd
+%config /etc/httpd/conf.d/rapid-tunneling.conf
%changelog
+* Sun Feb 01 2009 Alex Landau <alex.landau@xorcom.com> 1.01-1
+- Added password protection in the GUI.
+
* Sun Dec 14 2008 Alex Landau <alex.landau@xorcom.com> 1.0-1
- Initial RPM release.