summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorchipx86 <chipx86@5efc13c4-1f27-0410-8691-ff2d1f55687e>2009-07-18 21:55:11 +0000
committerchipx86 <chipx86@5efc13c4-1f27-0410-8691-ff2d1f55687e>2009-07-18 21:55:11 +0000
commitb431db585ae7a132bc9764b64770f86a61569ddf (patch)
treef18a11250fe5482ec8542cd350e2ccae50dd213f /setup.py
parent800a8edf576c2b4fa59c5796ee7aa74cc0da5c4d (diff)
Install post-review as a Python module, with a generated post-review (or
post-review.exe) wrapping it. The official way to install post-review now is by installing RBTools. Reviewed at http://reviews.review-board.org/r/916/
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 7 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index ec6d1d8..d848d23 100755
--- a/setup.py
+++ b/setup.py
@@ -40,14 +40,17 @@ else:
setup(name="RBTools",
version=VERSION,
license="MIT",
- description="Command line applications for use with Review Board",
- scripts=[
- "scripts/post-review",
- ],
+ description="Command line tools for use with Review Board",
+ entry_points = {
+ 'console_scripts': [
+ 'post-review = rbtools.postreview:main',
+ ],
+ },
install_requires=['simplejson'],
dependency_links = [
download_url,
],
+ packages=find_packages(),
include_package_data=True,
maintainer="Christian Hammond",
maintainer_email="chipx86@chipx86.com",