summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Hammond <chipx86@chipx86.com>2009-11-05 03:16:47 -0800
committerChristian Hammond <chipx86@chipx86.com>2009-11-05 03:16:47 -0800
commitb8e86ebfcf58cbf998ac981326c65f6ffb500a00 (patch)
treeec490e5bbec1f40ab589bb4dbc55db4ff19894ed /setup.py
parent62dd2130e5e510b8cbb90d827bc5ec8e332d3817 (diff)
Don't depend on simplejson on Python 2.6 eggs.
We were requiring the simplejson dependency on Python 2.6, despite the fact that Python 2.6 includes json built-in. We no longer depend on simplejson on this version. Fixes bug #1383
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6084b3c..08f4fbe 100755
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,15 @@ else:
download_url = "http://downloads.reviewboard.org/nightlies/"
+install_requires = []
+
+
+try:
+ import json
+except ImportError:
+ install_requires.append('simplejson')
+
+
setup(name=PACKAGE_NAME,
version=get_package_version(),
license="MIT",
@@ -46,7 +55,7 @@ setup(name=PACKAGE_NAME,
'post-review = rbtools.postreview:main',
],
},
- install_requires=['simplejson'],
+ install_requires=install_requires,
dependency_links = [
download_url,
],