summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2006-11-01 19:10:56 +0000
committerrussell <russell@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2006-11-01 19:10:56 +0000
commit48689826a94c19de3897757c18c07c767a501e43 (patch)
tree26e9f0d165cd1a1a0c92ce41eb91ddf6a10fc799 /configure.ac
parent15eb19afe3cbe114092a86b7d20825e21274a731 (diff)
Merged revisions 1547 via svnmerge from
https://origsvn.digium.com/svn/zaptel/branches/1.4 ........ r1547 | russell | 2006-11-01 14:04:02 -0500 (Wed, 01 Nov 2006) | 3 lines instead of setting HOSTCC and CC directly in the Makefile, use the information provided by the configure script (issue #8055, tzafrir) ........ git-svn-id: http://svn.digium.com/svn/zaptel/trunk@1548 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fbf880..fea925c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,10 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AST_CHECK_GNU_MAKE
+# Set the default value of HOSTCC from CC if --host was not provided:
+HOSTCC=${HOSTCC:=${CC}}
+AC_SUBST(HOSTCC)
+
AC_PATH_PROG([GREP], [grep], :)
AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)