summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-02-07 20:09:29 +0000
committerfile <file@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-02-07 20:09:29 +0000
commit614a39ced8799b3ec63cc738ee7dda095a6ea74c (patch)
tree2b8494e2302a18f50f90fed6e68b9e8b4391c70a /configure.ac
parent20aa812f076a7c2810e7acb4499a6e8b2282073c (diff)
Merged revisions 2107 via svnmerge from
https://origsvn.digium.com/svn/zaptel/branches/1.4 ........ r2107 | file | 2007-02-07 15:01:41 -0500 (Wed, 07 Feb 2007) | 2 lines Merge in zaptel-firmware branch. This basically downloads the firmware from the FTP site and builds the appropriate headers based on the current version. Drivers just know they need a certain firmware and get fed the current version. If this prevents your zaptel from building do a make distclean and start fresh or make sure the firmware is checked in make menuselect. ........ git-svn-id: http://svn.digium.com/svn/zaptel/trunk@2108 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 522b8f6..f2b916e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,15 @@ AC_PATH_PROG([GREP], [grep], :)
AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
+AC_PATH_PROG([WGET], [wget], :)
+if test "${WGET}" != ":" ; then
+ DOWNLOAD=${WGET}
+else
+ AC_PATH_PROG([FETCH], [fetch], [:])
+ DOWNLOAD=${FETCH}
+fi
+AC_SUBST(DOWNLOAD)
+
AC_LANG(C)
AST_EXT_LIB([curses], [initscr], [curses.h], [CURSES], [curses], [])