summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCorey Farrell <git@cfware.com>2017-08-02 15:16:43 -0400
committerCorey Farrell <git@cfware.com>2017-08-02 18:10:57 -0400
commit4b03eb5c3822765a49b7ab4b05294ce7c012522b (patch)
tree78391dbd1c3d36d507608cb8b89772ca3ee9ec52 /configure.ac
parent2be8d91c0f5802a1f9c87b35f8f419e0db1b22d8 (diff)
Fix compile error for old versions of GCC.
Use -Wno-format-truncation only if supported by compiler. ASTERISK-27171 #close Change-Id: Iac0aed7a5bcaa16c21b7d62c4e4678d244c4ccb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2eaab4ad..32b5fc09b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1252,6 +1252,16 @@ else
fi
AC_SUBST(AST_NO_STRICT_OVERFLOW)
+AC_MSG_CHECKING(for -Wno-format-truncation)
+if $(${CC} -O2 -Wno-format-truncation -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
+ AC_MSG_RESULT(yes)
+ AST_NO_FORMAT_TRUNCATION=-Wno-format-truncation
+else
+ AC_MSG_RESULT(no)
+ AST_NO_FORMAT_TRUNCATION=
+fi
+AC_SUBST(AST_NO_FORMAT_TRUNCATION)
+
AC_MSG_CHECKING(for -Wshadow)
if $(${CC} -Wshadow -S -o /dev/null -xc /dev/null > /dev/null 2>&1); then
AC_MSG_RESULT(yes)