summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2017-11-17 09:26:33 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2017-11-17 09:26:33 -0600
commit4dac92b99a2becf88d493b8ae1a0cdb714766e23 (patch)
treed16c42100ddd749738b037ebb6b9dd05a01b5092 /configure.ac
parentb2c49d6c07d5ec2781c086c422ff8b90bf6a921c (diff)
parente9f8b317c38a36a8f4543ca77f785cb498ff567c (diff)
Merge "Build: Make function constructor/destructor attributes mandatory."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 91da555a4..47c6b26d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1150,7 +1150,14 @@ AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
AST_GCC_ATTRIBUTE(may_alias)
AST_GCC_ATTRIBUTE(constructor)
+if test "$ax_cv_have_func_attribute_constructor" != "1"; then
+ AC_MSG_ERROR([*** Function constructor attribute is not supported by your compiler.])
+fi
+
AST_GCC_ATTRIBUTE(destructor)
+if test "$ax_cv_have_func_attribute_destructor" != "1"; then
+ AC_MSG_ERROR([*** Function destructor attribute is not supported by your compiler.])
+fi
AST_GCC_ATTRIBUTE(noreturn,noreturn)
AC_MSG_CHECKING(for -fsanitize=address support)