summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2009-06-16 16:32:36 +0000
committerKevin P. Fleming <kpfleming@digium.com>2009-06-16 16:32:36 +0000
commit10ea4910e708eb912395b9fa137dbac2e7868950 (patch)
tree0a9e072b735507f3f3e340e4c16046aa4140ea9e /configure.ac
parentee8cdd555ff058a3ed955a6bbbf0ced01d1694e3 (diff)
Fix problems with new compiler attribute checking in configure script.
The last changes to ast_gcc_attribute.m4 caused some problems checking for various attributes, because the scope of the symbol the attribute is applied to can be important; this patch allows the scope to be specified for the check. git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@200985 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cfb53fd7f..de7892fc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -515,7 +515,7 @@ AST_GCC_ATTRIBUTE(deprecated)
AST_GCC_ATTRIBUTE(sentinel)
AST_GCC_ATTRIBUTE(warn_unused_result)
AST_GCC_ATTRIBUTE(weakref, [weakref("foo")])
-AST_GCC_ATTRIBUTE(weak_import)
+AST_GCC_ATTRIBUTE(weak_import, , "")
AC_MSG_CHECKING(for -ffunction-sections support)
saved_CFLAGS="${CFLAGS}"