summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJenkins2 <jenkins2@gerrit.asterisk.org>2018-01-20 01:24:24 -0600
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-01-20 01:24:24 -0600
commit1376aa3f2999a760e983d5761cf608bfe15a38b8 (patch)
treef769926ce7a16cbe1f05ecabb00c47358632cb01 /configure.ac
parent51313e304e9dd57342a9b5715b8a1ce908d0674e (diff)
parent8f31b7024621f1be7dfc998c1a6dfd714a3b6197 (diff)
Merge "BuildSystem: Detect external library Lua in version 5.3."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64ecbfab3..962e80405 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2409,6 +2409,15 @@ if test "${PBX_PWLIB}" = "1" -a "${USE_OPENH323}" != "no" ; then
[${PWLIB_INCLUDE}], [${PWLIB_LIB}])
fi
+AST_EXT_LIB_CHECK([LUA], [lua5.3], [luaL_newstate], [lua5.3/lua.h], [-lm])
+if test "x${PBX_LUA}" = "x1" ; then
+ if test x"${LUA_DIR}" = x; then
+ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua5.3"
+ else
+ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua5.3"
+ fi
+fi
+
AST_EXT_LIB_CHECK([LUA], [lua5.2], [luaL_newstate], [lua5.2/lua.h], [-lm])
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then