summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid M. Lee <dlee@digium.com>2012-12-13 16:43:40 +0000
committerDavid M. Lee <dlee@digium.com>2012-12-13 16:43:40 +0000
commit24b0d2365b4844c2439e6540528264cd4ea03f16 (patch)
tree26720c8f5e5b728bfc3435c6be1a1303850e113b /configure.ac
parentfad26372972027531474d122f68b02ea66255287 (diff)
Bail configure if it can't find libuuid.
git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@377981 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 377124184..2b72b4e76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -510,6 +510,10 @@ else
fi
AC_SUBST(EDITLINE_LIB)
+if test "x$UUID_LIB" == "x"; then
+ AC_MSG_ERROR([*** uuid support not found (this typically means the uuid development package is missing)])
+fi
+
# Another mandatory item (unless it's explicitly disabled)
AC_ARG_ENABLE([xmldoc],
[AS_HELP_STRING([--disable-xmldoc],