summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Traud <pabstraud@compuserve.com>2018-02-16 11:50:54 +0100
committerAlexander Traud <pabstraud@compuserve.com>2018-02-16 11:57:18 +0100
commit2c814afb861d08fbc9a38b59b1814c3f4160e8e7 (patch)
treea69e94127f827c39ed6f347f1bfb454ec8a4685c /configure.ac
parentbe2292a2f51fbe05945998f183572ab1ca6473dc (diff)
BuildSystem: Enable system provided libedit on OpenBSD.
ASTERISK-27677 Change-Id: I0854e3616d1361ae9b6907d3d3444a02784ac62b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cef28f5b0..c21891286 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1577,12 +1577,15 @@ if test "${USE_ILBC}" != "no"; then
fi
AST_PKG_CONFIG_CHECK(LIBEDIT, libedit)
-AST_C_COMPILE_CHECK([LIBEDIT_IS_UNICODE], [el_rfunc_t *callback;], [histedit.h], [], [Testing for libedit unicode support])
-
+if test "${PBX_LIBEDIT}" != 1; then
+ # some platforms do not list libedit via pkg-config, for example OpenBSD 6.2
+ AST_EXT_LIB_CHECK([LIBEDIT], [edit], [history_init], [histedit.h], [-ltermcap])
+fi
if test "${PBX_LIBEDIT}" != 1; then
AC_MSG_ERROR(*** Please install the 'libedit' development package.)
exit 1
fi
+AST_C_COMPILE_CHECK([LIBEDIT_IS_UNICODE], [el_rfunc_t *callback;], [histedit.h], [], [Testing for libedit unicode support])
AST_EXT_LIB_CHECK([ICONV], [iconv], [iconv_open], [iconv.h])
# GNU libiconv #define's iconv_open to libiconv_open, so we need to search for that symbol