summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2007-06-29 21:24:40 +0000
committerRussell Bryant <russell@russellbryant.com>2007-06-29 21:24:40 +0000
commit4a6f3770f9e0b96956be68a3e530e286134c856d (patch)
tree45bd741392c5eea6f6512dae3be9ee1421a7b2b2 /configure.ac
parent2392758621b05823c224a0b5e5d7bc74c2f29137 (diff)
Fix my recent change for sending large files via the http server. This code
*must* write the file to the FILE *, and not the raw fd. Otherwise, it breaks TLS support. Thanks to rizzo for catching this! git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@72738 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 9e8279d07..4c4a48c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,23 +364,6 @@ AC_CHECK_HEADER([libkern/OSAtomic.h],
AC_CHECK_SIZEOF(int)
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <stdlib.h>
- #include <sys/sendfile.h>],
- [sendfile(1, 0, NULL, 1);])
- ],[
- AC_MSG_RESULT(yes)
- have_sendfile=yes
- ],[
- AC_MSG_RESULT(no)
- have_sendfile=no
- ]
-)
-if test "${have_sendfile}" = "yes"; then
- AC_DEFINE([HAVE_SENDFILE], 1, [Define if your system has the sendfile syscall.])
-fi
-
# do the package library checks now
AST_EXT_LIB_CHECK([ALSA], [asound], [snd_spcm_init], [alsa/asoundlib.h], [-lm -ldl])