summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Traud <pabstraud@compuserve.com>2018-01-15 17:57:11 +0100
committerAlexander Traud <pabstraud@compuserve.com>2018-01-15 17:57:11 +0100
commit645297614e2d2d69156ec166b13cedeac12bd0df (patch)
tree8c692170da9c9f2db01983fa974e7ea1dd45517d /configure.ac
parent6f1f16d88720db2f0c29f323dce2ba065cb0c9ce (diff)
BuildSystem: Resolve resolv.h not via Generic but Particular Header-Check.
ASTERISK-27585 Change-Id: I27c67563788e6f67eeda5fb51a741823a50a95e2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f0a978ee4..f68338b2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,11 +605,16 @@ if test "$ac_cv_header_sys_wait_h" != "yes"; then
AC_MSG_ERROR([*** POSIX.1 compatible sys/wait.h is required.])
fi
+AC_HEADER_RESOLV
+if test "$ac_cv_header_resolv_h" != "yes"; then
+ AC_MSG_ERROR([*** resolv.h is required.])
+fi
+
# Check for headers that are unconditionally required on all platforms. Do not use
# this to check for headers that are only needed by modules.
AC_CHECK_HEADERS([ \
arpa/nameser.h assert.h ctype.h dlfcn.h errno.h fcntl.h float.h grp.h \
- inttypes.h limits.h locale.h math.h pwd.h netinet/in.h regex.h resolv.h \
+ inttypes.h limits.h locale.h math.h pwd.h netinet/in.h regex.h \
sched.h stdarg.h stdint.h stdio.h stdlib.h string.h syslog.h \
sys/file.h sys/ioctl.h sys/param.h sys/resource.h sys/socket.h sys/stat.h \
sys/time.h sys/types.h sys/un.h \