summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTerry Wilson <twilson@digium.com>2010-08-13 16:08:05 +0000
committerTerry Wilson <twilson@digium.com>2010-08-13 16:08:05 +0000
commit75033d0735c9ac52d667de1377bf8c7083ce788c (patch)
tree2303107e09370340ea4d640b3169f90277bf1350 /configure.ac
parent377c3bf88ee9888ca51dfe53ba66eda34f79ce0b (diff)
Merged revisions 282200-282201 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.8 ........ r282200 | twilson | 2010-08-13 11:00:02 -0500 (Fri, 13 Aug 2010) | 10 lines Detect when libsrtp cannot be linked in a shared library The libsrtp build system currently does not produce a shared library or a static library compiled with -fPIC, so on 64-bit systems it is possible that we will get a compile error if libsrtp is installed and res_srtp is selected in menuselect. This patch attempts to detect this situation and provide the user with instructions to work around the problem. ........ r282201 | twilson | 2010-08-13 11:02:20 -0500 (Fri, 13 Aug 2010) | 2 lines Whitespace fix :-/ ........ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@282202 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dfc45a5e8..62e7895c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1807,6 +1807,38 @@ fi
AST_EXT_LIB_CHECK([SRTP], [srtp], [srtp_init], [srtp/srtp.h])
+if test "$PBX_SRTP" = "1";
+then
+ saved_libs="${LIBS}"
+ saved_ldflags="${LDFLAGS}"
+ LIBS="${LIBS} -lsrtp"
+ LDFLAGS="${LDFLAGS} -shared -fPIC"
+ AC_MSG_CHECKING(for the ability of -lsrtp to be linked in a shared object)
+ AC_LINK_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <srtp/srtp.h>],
+ [srtp_init();]
+ )
+ ],
+ [ AC_MSG_RESULT(yes) ],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_NOTICE(***)
+ AC_MSG_NOTICE(*** libsrtp could not be linked as a shared object)
+ AC_MSG_NOTICE(*** try compiling libsrtp manually and configuring with)
+ AC_MSG_NOTICE(*** ./configure CFLAGS=-fPIC --prefix=/usr)
+ AC_MSG_NOTICE(*** replacing /usr with the prefix of your choice)
+ AC_MSG_NOTICE(***)
+ AC_MSG_NOTICE(*** If you do not need SRTP support re-run configure)
+ AC_MSG_NOTICE(*** with the --without-srtp option.)
+ exit 1
+ ]
+ )
+ LIBS="${saved_libs}"
+ LDFLAGS="${saved_ldflags}"
+fi
+
AST_EXT_TOOL_CHECK([GMIME], [gmime-config], [], [], [#include <gmime/gmime.h>], [gboolean q = g_mime_check_version(0,0,0);])
AST_EXT_LIB_CHECK([HOARD], [hoard], [malloc], [])