summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilghman Lesher <tilghman@meg.abyt.es>2010-07-15 19:46:57 +0000
committerTilghman Lesher <tilghman@meg.abyt.es>2010-07-15 19:46:57 +0000
commit753fa3b278e8c7f78956ccb299bd1f74a8a7fdfd (patch)
treea4571e3a1776437a30b66696778eb88958104168 /configure.ac
parente2ff55122d36c1190599be67d8e0ffb306c231bd (diff)
Define LLONG_MAX on systems that do not have it.
(closes issue #17644) Reported by: pprindeville git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@276769 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 98005f015..4bfac0af8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -462,6 +462,15 @@ if test "x${ac_cv_type_long_double_wider}" = "xyes" ; then
AC_CHECK_FUNCS([exp2l log2l exp10l log10l sinl cosl tanl asinl acosl atanl atan2l powl sqrtl rintl expl logl remainderl fmodl roundl truncl floorl ceill])
fi
+AC_MSG_CHECKING(for LLONG_MAX in limits.h)
+AC_LINK_IFELSE(
+ AC_LANG_PROGRAM([#include <limits.h>],
+ [long long foo = LLONG_MAX]),
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_LLONG_MAX], 1, [Define to 1 if limits.h includes a LLONG_MAX definition.]),
+ AC_MSG_RESULT(no)
+)
+
AC_MSG_CHECKING(for timersub in time.h)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <sys/time.h>],