summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Traud <pabstraud@compuserve.com>2018-03-08 16:04:29 +0100
committerAlexander Traud <pabstraud@compuserve.com>2018-03-08 16:04:29 +0100
commit75cebc3e71560e080c7157882583652684a3d720 (patch)
treeeca67f07112684f45a4c0edadc9d0b5e975d1539 /configure.ac
parent9040057db38dbc3d8181a5405d13ed8c8083d438 (diff)
BuildSystem: Re-check for another UUID library only when previous check failed.
As a side-effect, this avoids the ambiguous output: checking for uuid_generate_random... no which was printed always previously. ASTERISK-25586 Reported by: John Nemeth Change-Id: I6d541dfcf453932a9856c5e251aa22e0e6c233c9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index a59646cfd..6335533db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -638,20 +638,23 @@ AC_SUBST(EDITLINE_LIB)
# * -le2fs-uuid on OpenBSD
# * in libsystem on OS X
AST_EXT_LIB_CHECK([LIBUUID], [uuid], [uuid_generate_random], [uuid/uuid.h], [])
-AST_EXT_LIB_CHECK([E2FSUUID], [e2fs-uuid], [uuid_generate_random], [uuid/uuid.h], [])
-AC_CHECK_FUNCS([uuid_generate_random], [SYSUUID=true], [SYSUUID=""])
-
if test "x$LIBUUID_LIB" != "x" ; then
UUID_INCLUDE="$LIBUUID_INCLUDE"
UUID_LIB="$LIBUUID_LIB"
-elif test "x$E2FSUUID_LIB" != "x" ; then
- UUID_INCLUDE="$E2FSUUID_INCLUDE"
- UUID_LIB="$E2FSUUID_LIB"
-elif test "x$SYSUUID" != "x" ; then
- UUID_INCLUDE=""
- UUID_LIB=""
else
- AC_MSG_ERROR([*** uuid support not found (this typically means the uuid development package is missing)])
+ AST_EXT_LIB_CHECK([E2FSUUID], [e2fs-uuid], [uuid_generate_random], [uuid/uuid.h], [])
+ if test "x$E2FSUUID_LIB" != "x" ; then
+ UUID_INCLUDE="$E2FSUUID_INCLUDE"
+ UUID_LIB="$E2FSUUID_LIB"
+ else
+ AC_CHECK_FUNCS([uuid_generate_random], [SYSUUID=true], [SYSUUID=""])
+ if test "x$SYSUUID" != "x" ; then
+ UUID_INCLUDE=""
+ UUID_LIB=""
+ else
+ AC_MSG_ERROR([*** uuid support not found (this typically means the uuid development package is missing)])
+ fi
+ fi
fi
AC_SUBST(UUID_INCLUDE)
AC_SUBST(UUID_LIB)