summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Traud <pabstraud@compuserve.com>2018-02-12 14:37:41 +0100
committerAlexander Traud <pabstraud@compuserve.com>2018-02-14 09:28:29 +0100
commit8ac198aff3422ef624bb28ba8c3830a771e14645 (patch)
tree1644046194ac476256da221a68d08ea35c4e9046 /configure.ac
parent41a05aacc95a2cfc80b3c232be02efc4ae380103 (diff)
BuildSystem: Remove chan_h323 leftovers.
ASTERISK-27670 Change-Id: I07a8ef8bbd6001e25711fa1bff152eb6c9efa729
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index cef28f5b0..2029917f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -460,7 +460,6 @@ AST_EXT_LIB_SETUP([GSM], [External GSM], [gsm], [, use 'internal' GSM otherwise]
AST_EXT_LIB_SETUP([ILBC], [System iLBC], [ilbc], [, use 'internal' iLBC otherwise])
AST_EXT_LIB_SETUP([GTK2], [gtk2], [gtk2])
AST_EXT_LIB_SETUP([GMIME], [GMime], [gmime])
-AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
AST_EXT_LIB_SETUP([HOARD], [Hoard Memory Allocator], [hoard])
AST_EXT_LIB_SETUP([ICAL], [iCal], [ical])
AST_EXT_LIB_SETUP([ICONV], [Iconv], [iconv])
@@ -541,7 +540,6 @@ AST_EXT_LIB_SETUP_OPTIONAL([PRI_PROG_W_CAUSE], [ISDN progress with cause], [PRI]
AST_EXT_LIB_SETUP_OPTIONAL([PRI_SERVICE_MESSAGES], [ISDN service messages], [PRI], [pri])
AST_EXT_LIB_SETUP_OPTIONAL([PRI_REVERSE_CHARGE], [ISDN reverse charge], [PRI], [pri])
# ------------------------------------^
-AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
AST_EXT_LIB_SETUP([FFTW3], [LIBFFTW3], [fftw3])
AST_EXT_LIB_SETUP([RESAMPLE], [LIBRESAMPLE], [resample])
@@ -2359,42 +2357,6 @@ if test -z "$__opus_include" -o x"$__opus_include" = x" " ; then
fi
AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
-if test "${USE_PWLIB}" != "no"; then
- if test -n "${PWLIB_DIR}"; then
- PWLIBDIR="${PWLIB_DIR}"
- fi
- AST_CHECK_PWLIB()
- AST_CHECK_PWLIB_VERSION([PWLib], [PWLIB], [ptbuildopts.h], [1], [9], [2], [P[[WT]]LIB_VERSION])
-
- if test "${HAS_PWLIB:-unset}" != "unset"; then
- AST_CHECK_PWLIB_PLATFORM()
-
- PLATFORM_PWLIB="pt_${PWLIB_PLATFORM}_r"
-
- AST_CHECK_PWLIB_BUILD([PWLib], [PWLIB],
- [Define if your system has the PWLib libraries.],
- [#include "ptlib.h"],
- [int q = (int) PTime::IsDaylightSavings();])
- fi
-fi
-
-if test "${PBX_PWLIB}" = "1" -a "${USE_OPENH323}" != "no" ; then
- if test -n "${OPENH323_DIR}"; then
- OPENH323DIR="${OPENH323_DIR}"
- fi
- AST_CHECK_OPENH323()
- AST_CHECK_PWLIB_VERSION([OpenH323], [OPENH323], [openh323buildopts.h], [1], [17], [3], [], [1], [19], [0])
- AST_CHECK_OPENH323_BUILD()
- PLATFORM_OPENH323="h323_${PWLIB_PLATFORM}_${OPENH323_SUFFIX}"
- AST_CHECK_PWLIB_BUILD([OpenH323], [OPENH323],
- [Define if your system has the OpenH323 libraries.],
- [#include "ptlib.h"
- #include "h323.h"
- #include "h323ep.h"],
- [H323EndPoint ep = H323EndPoint();],
- [${PWLIB_INCLUDE}], [${PWLIB_LIB}])
-fi
-
AST_EXT_LIB_CHECK([LUA], [lua5.3], [luaL_newstate], [lua5.3/lua.h], [-lm])
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then