summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCorey Farrell <git@cfware.com>2018-02-12 02:26:56 -0500
committerCorey Farrell <git@cfware.com>2018-02-12 04:44:26 -0500
commit9fddc8b4dceb0e53e62892a1223b353c415e0503 (patch)
tree7627721b2ad1c9460f331335e5f3162c88057359 /configure.ac
parente132f22a2ef89ca7b7fa7e9a77d4e1aad64bf203 (diff)
core: Remove embedded editline.
This removes the embedded copy of editline from the Asterisk source tree, making a system copy of libedit mandatory in Asterisk 16+. ASTERISK-27634 #close Change-Id: Iedb64ad92acb78419f3caefedaa2bb7cd2a1a33f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 7 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 4b918837e..cef28f5b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -475,7 +475,7 @@ AST_EXT_LIB_SETUP([URIPARSER], [uriparser library], [uriparser])
AST_EXT_LIB_SETUP([KQUEUE], [kqueue support], [kqueue])
AST_EXT_LIB_SETUP([LDAP], [OpenLDAP], [ldap])
AST_LIBCURL_CHECK_CONFIG([], [7.10.1])
-AST_EXT_LIB_SETUP([LIBEDIT], [NetBSD Editline library], [libedit], [, use 'internal' Editline otherwise])
+AST_EXT_LIB_SETUP([LIBEDIT], [NetBSD Editline library], [libedit])
AST_EXT_LIB_SETUP_OPTIONAL([LIBEDIT_IS_UNICODE], [Libedit compiled for unicode], [LIBEDIT], [libedit])
AST_EXT_LIB_SETUP([LIBXML2], [LibXML2], [libxml2])
AST_EXT_LIB_SETUP([LIBXSLT], [LibXSLT], [libxslt])
@@ -1576,27 +1576,12 @@ if test "${USE_ILBC}" != "no"; then
fi
fi
-LIBEDIT_INTERNAL="yes"
-AC_SUBST(LIBEDIT_INTERNAL)
-LIBEDIT_SYSTEM="yes"
-if test "${USE_LIBEDIT}" != "no"; then
- if test "${LIBEDIT_DIR}" = "internal"; then
- LIBEDIT_SYSTEM="no"
- elif test "${LIBEDIT_DIR}" != ""; then
- LIBEDIT_INTERNAL="no"
- fi
- if test "${LIBEDIT_SYSTEM}" = "yes"; then
- AST_PKG_CONFIG_CHECK(LIBEDIT, libedit)
- if test "$PBX_LIBEDIT" = "1"; then
- LIBEDIT_INTERNAL="no"
- fi
- fi
- if test "${LIBEDIT_INTERNAL}" = "yes"; then
- PBX_LIBEDIT=1
- LIBEDIT_IS_UNICODE=no
- else
- AST_C_COMPILE_CHECK([LIBEDIT_IS_UNICODE], [el_rfunc_t *callback;], [histedit.h], [], [Testing for libedit unicode support])
- fi
+AST_PKG_CONFIG_CHECK(LIBEDIT, libedit)
+AST_C_COMPILE_CHECK([LIBEDIT_IS_UNICODE], [el_rfunc_t *callback;], [histedit.h], [], [Testing for libedit unicode support])
+
+if test "${PBX_LIBEDIT}" != 1; then
+ AC_MSG_ERROR(*** Please install the 'libedit' development package.)
+ exit 1
fi
AST_EXT_LIB_CHECK([ICONV], [iconv], [iconv_open], [iconv.h])