summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Jordan <mjordan@digium.com>2013-02-22 01:52:14 +0000
committerMatthew Jordan <mjordan@digium.com>2013-02-22 01:52:14 +0000
commita3b138429f2a9475acec0470cc43d4a0846ec4a3 (patch)
tree388ca622d3a31fd0717ca3785665f2f107b5de05 /configure.ac
parent5e9994ed9c53a61613ce1a8bc84f58f04f311796 (diff)
Properly detect launchd
Asterisk was a little too pro-active in claiming that it found launchd. On systems without launchd - such as FreeBSD - this resulted in certain items in Asterisk that conflict with launchd to not be selectable, such as res_timing_kqueue. (closes issue ASTERISK-20749) Reported by: Oleg Baranov ........ Merged revisions 381847 from http://svn.asterisk.org/svn/asterisk/branches/1.8 ........ Merged revisions 381848 from http://svn.asterisk.org/svn/asterisk/branches/11 git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@381869 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 477e98199..d7fc6c266 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2296,7 +2296,9 @@ PBX_LAUNCHD=0
if test "${cross_compiling}" = "no";
then
AC_CHECK_FILE(/sbin/launchd, AC_DEFINE([HAVE_SBIN_LAUNCHD], 1, [Define to 1 if your system has /sbin/launchd.]))
- PBX_LAUNCHD=1
+ if test "${HAVE_SBIN_LAUNCHD}" = 1; then
+ PBX_LAUNCHD=1
+ fi
fi
AC_SUBST(PBX_LAUNCHD)