summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid M. Lee <dlee@respoke.io>2016-12-16 01:32:57 -0600
committerGeorge Joseph <gjoseph@digium.com>2016-12-16 07:53:11 -0600
commitab447f8a6a3d05908395ed52ec3b981c1e8943c1 (patch)
treea6051f3778e4f0e8c041ac7cfe1ae914ab4e0c66 /configure.ac
parent91485734a48e9e44292b80b8993fb464bc3817b0 (diff)
configure: fix with-pjproject-bundled
The AC_ARG_WITH macro's shell variable is withval; not enableval. Purely coincidentally, the option would work when --enable-dev-mode is given. Also fixed a portability problem with bootstrap.sh, since -printf is not a portable option for find. Change-Id: I0f0e5b1a934b5af5737713834361e9c95b96b376
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 82ebbc1c0..931abe19f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -431,7 +431,7 @@ AH_TEMPLATE(m4_bpatsubst([[HAVE_PJPROJECT_BUNDLED]], [(.*)]), [Define to 1 when
AC_ARG_WITH([pjproject-bundled],
[AS_HELP_STRING([--with-pjproject-bundled],
[Use bundled pjproject libraries])],
- [case "${enableval}" in
+ [case "${withval}" in
n|no) PJPROJECT_BUNDLED=no ;;
*) PJPROJECT_BUNDLED=yes ;;
esac])