summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Colp <jcolp@digium.com>2018-03-14 06:17:01 -0500
committerGerrit Code Review <gerrit2@gerrit.digium.api>2018-03-14 06:17:01 -0500
commitbaf06002fe426d7c309fd8e81c5c6b8129f21f5b (patch)
tree1a16ddae5797fd92ecf7741dfc6042889edb13fc /configure.ac
parent6d81a2a684e75e301fffb5df6671057794e4d43d (diff)
parent5b525c9781ce63e9d8143adc3666f87cb12bacc7 (diff)
Merge "BuildSystem: Add NetBSD."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1895c4185..077cf8352 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,11 @@ case "${host_os}" in
esac
case "${host_os}" in
+ netbsd*)
+ ac_default_prefix=/usr/pkg
+ CPPFLAGS=-I/usr/pkg/include
+ LDFLAGS=-L/usr/pkg/lib
+ ;;
freebsd*)
ac_default_prefix=/usr/local
CPPFLAGS=-I/usr/local/include
@@ -1316,6 +1321,9 @@ AC_ARG_ENABLE(rpath,
AC_MSG_CHECKING(whether to use rpath)
AST_RPATH=
+if test "${OSARCH}" = "NetBSD"; then
+ AST_RPATH="-Wl,-rpath,/usr/pkg/lib"
+fi
if test "${check_rpath}" != yes; then
AC_MSG_RESULT(skipped)
elif test "${prefix}" = /usr || test "${prefix}" = NONE; then