summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <russell@russellbryant.com>2006-12-01 23:20:17 +0000
committerRussell Bryant <russell@russellbryant.com>2006-12-01 23:20:17 +0000
commitc1a36cb52f73a797c19fe9758465da3d5d96e682 (patch)
treeab0579503ca22a9240d42260ad3f01b31a56f979 /configure.ac
parente3b099c12a80652a452e63d6543381b7c8bd68be (diff)
Merged revisions 48190 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r48190 | russell | 2006-12-01 18:16:28 -0500 (Fri, 01 Dec 2006) | 12 lines FreeBSD 6.1 does not include wget by default. However, it has fetch which will work just fine for our purposes of downloading the sounds packages. So, check for both wget and fetch and the configure script and use what was found to download them. If neither one was found, and sound packages are selected that must be downloaded, the install process will print out an informative error message indicating the situation. Also, fix a couple places where "make" was hard coded into some output messages by replacing them with the $(MAKE) variable. (issue #8451, initial patch by pabelanger, with additional modifications by me) ........ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@48191 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9519beb5..f86d9965b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,14 @@ AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
AC_PATH_PROG([DOT], [dot], :)
AC_PATH_PROG([STRIP], [strip], :)
+AC_PATH_PROG([WGET], [wget], :)
+if test "${WGET}" != ":" ; then
+ DOWNLOAD=${WGET}
+else
+ AC_PATH_PROG([FETCH], [fetch], [:])
+ DOWNLOAD=${FETCH}
+fi
+AC_SUBST(DOWNLOAD)
AC_LANG(C)