summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean Bright <sean@malleable.com>2009-07-30 23:37:31 +0000
committerSean Bright <sean@malleable.com>2009-07-30 23:37:31 +0000
commitc3ab548cd862597e6241a5309b81d25a5efd08b8 (patch)
tree7e42188206184b3c23c8feedd189052fccff1c57 /configure.ac
parentbab2f5731667734c2b4162e10bf086f744cac52b (diff)
Allow passing 'noisy' to configure's --enable-dev-mode argument to turn on verbose builds.
(closes issue #15607) Reported by: mvanbaak Patches: 20090730_issue15607.patch uploaded by seanbright (license 71) Tested by: seanbright git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@209623 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38c43ca27..4e2d0decc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,8 +214,13 @@ AC_ARG_ENABLE([dev-mode],
[case "${enableval}" in
y|ye|yes) AST_DEVMODE=yes ;;
n|no) AST_DEVMODE=no ;;
+ noisy)
+ AST_DEVMODE=yes
+ NOISY_BUILD=yes
+ ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-dev-mode) ;;
esac])
+AC_SUBST(NOISY_BUILD)
AC_SUBST(AST_DEVMODE)
# AST_EXT_LIB_SETUP is used to tell configure to handle variables for