summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin P. Fleming <kpfleming@digium.com>2007-05-25 14:37:55 +0000
committerKevin P. Fleming <kpfleming@digium.com>2007-05-25 14:37:55 +0000
commitc74518e3ff958e4087ee7de34418ae0b57f6aeac (patch)
treec8a19d6fa9f9ea03bc06e0322f5931cc741c1a73 /configure.ac
parentf65934a517d9d5109d3c049fd48a34b6d40fdf2a (diff)
Merged revisions 66157 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r66157 | kpfleming | 2007-05-25 10:28:46 -0400 (Fri, 25 May 2007) | 3 lines handle the GNUTLS library properly in the configure script and build system don't build in OSP support unless we have found and are allowed to use SSL support ........ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@66158 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 185eb3d3e..1e85808a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -431,10 +431,7 @@ fi
AST_EXT_LIB_CHECK([IKSEMEL], [iksemel], [iks_start_sasl], [iksemel.h])
if test "${PBX_IKSEMEL}" = 1; then
- AST_EXT_LIB_CHECK([GNUTLS], [gnutls], [gnutls_bye])
- if test "${PBX_GNUTLS}" = 1; then
- IKSEMEL_LIB="${IKSEMEL_LIB} -lgnutls -lz -lgcrypt -lgpg-error"
- fi
+ AST_EXT_LIB_CHECK([GNUTLS], [gnutls], [gnutls_bye], [gnutls/gnutls.h], [-lz -lgcrypt -lgpg-error])
fi
if test "${USE_IMAP_TK}" != "no"; then
@@ -678,7 +675,10 @@ AST_EXT_LIB_CHECK([UNIXODBC], [odbc], [SQLConnect], [sql.h], [-lltdl])
AST_EXT_LIB_CHECK([OGG], [ogg], [ogg_sync_init], [])
-AST_EXT_LIB_CHECK([OSPTK], [osptk], [OSPPCryptoDecrypt], [osp/osp.h], [-lcrypto -lssl])
+if test "$PBX_OPENSSL" = "1";
+then
+ AST_EXT_LIB_CHECK([OSPTK], [osptk], [OSPPCryptoDecrypt], [osp/osp.h], [-lcrypto -lssl])
+fi
AST_EXT_LIB_CHECK([BKTR], [execinfo], [backtrace], [execinfo.h], [-lexecinfo])