summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDoug Bailey <dbailey@digium.com>2009-04-21 14:28:04 +0000
committerDoug Bailey <dbailey@digium.com>2009-04-21 14:28:04 +0000
commitf431c867dd9b817501b8c475412eee310286b2e0 (patch)
tree9769d3d121d4fa2d64c6408c531cd3e24ff7c5ba /configure.ac
parent8e39288f6156af2bfc1f601c0680eb7cc4190d34 (diff)
Merged revisions 189601 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r189601 | dbailey | 2009-04-21 09:00:55 -0500 (Tue, 21 Apr 2009) | 3 lines Add check in configure script to check for GLOB_NOMAGIC and GLOB_BRACE in glob.h This allows config.c to compile when linked against uclibc that does not support these parameters ........ git-svn-id: https://origsvn.digium.com/svn/asterisk/trunk@189629 65c4cc65-6c06-0410-ace0-fbb531ad65f3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00220d238..6fff95fb9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -609,6 +609,10 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(no)
)
+AST_C_DEFINE_CHECK([GLOB_NOMAGIC], [GLOB_NOMAGIC], [glob.h])
+
+AST_C_DEFINE_CHECK([GLOB_BRACE], [GLOB_BRACE], [glob.h])
+
AST_C_DEFINE_CHECK([IP_MTU_DISCOVER], [IP_MTU_DISCOVER], [netinet/in.h])
AC_CHECK_HEADER([libkern/OSAtomic.h],