summaryrefslogtreecommitdiff
path: root/menuselect/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'menuselect/configure.ac')
-rw-r--r--menuselect/configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/menuselect/configure.ac b/menuselect/configure.ac
index 29c43cb50..5945f5c9f 100644
--- a/menuselect/configure.ac
+++ b/menuselect/configure.ac
@@ -15,7 +15,6 @@ AC_CONFIG_SRCDIR([menuselect.c])
AC_CONFIG_HEADER(autoconfig.h)
AC_COPYRIGHT("Menuselect")
-AC_REVISION($Revision$)
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
@@ -81,37 +80,6 @@ AC_ARG_ENABLE([debug],
esac])
AC_SUBST(MENUSELECT_DEBUG)
-# Support weak symbols on a platform specific basis. The Mac OS X
-# (Darwin) support must be isolated from the other platforms because
-# it has caused other platforms to fail.
-#
-case "${OSARCH}" in
- darwin*)
- # Allow weak symbol support on Darwin platforms only because there
- # is active community support for it.
- # However, Darwin seems to break weak symbols for each new version.
- #
- AST_GCC_ATTRIBUTE(weak_import, [], [], PBX_WEAKREF)
-
- # Several other platforms including Linux have GCC versions that
- # define the weak attribute. However, this attribute is only
- # setup for use in the code by Darwin.
- AST_GCC_ATTRIBUTE(weak, [], [], PBX_WEAKREF)
- ;;
- linux-gnu)
- # Primarily support weak symbols on Linux platforms.
- #
- AST_GCC_ATTRIBUTE(weakref, [weakref("foo")], static, PBX_WEAKREF)
- ;;
- *)
- # Allow weak symbols on other platforms. However, any problems
- # with this feature on other platforms must be fixed by the
- # community.
- #
- AST_GCC_ATTRIBUTE(weakref, [weakref("foo")], static, PBX_WEAKREF)
- ;;
-esac
-
AC_FUNC_ALLOCA
AC_CHECK_FUNCS([asprintf getloadavg setenv strcasestr strndup strnlen strsep unsetenv vasprintf])