summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debpathes16
-rw-r--r--debian/patches/import_time13
-rw-r--r--debian/patches/nodendor37
-rw-r--r--debian/patches/series3
4 files changed, 69 insertions, 0 deletions
diff --git a/debian/patches/debpathes b/debian/patches/debpathes
new file mode 100644
index 0000000..38ec3eb
--- /dev/null
+++ b/debian/patches/debpathes
@@ -0,0 +1,16 @@
+Author: Tzafrir Cohen <tzafrir@debian.org>
+Description: Pathes that match Debian packaging
+
+--- a/share/init.d/plinth
++++ b/share/init.d/plinth
+@@ -11,8 +11,8 @@
+ ### END INIT INFO
+
+ # This file is /etc/init.d/plinth
+-DAEMON=/usr/local/bin/plinth.py
+-EXMACHINA_DAEMON=/usr/local/bin/exmachina.py
++DAEMON=/usr/bin/plinth
++EXMACHINA_DAEMON=/usr/share/pyshared/exmachina/exmachina.py
+ PID_FILE=/var/run/plinth.pid
+ EXMACHINA_PID_FILE=/var/run/exmachina.pid
+
diff --git a/debian/patches/import_time b/debian/patches/import_time
new file mode 100644
index 0000000..4f5d866
--- /dev/null
+++ b/debian/patches/import_time
@@ -0,0 +1,13 @@
+Author: Tzafrir Cohen <tzafrir@debian.org>
+Desription: Missing import from auth.py
+
+--- a/modules/installed/lib/auth.py
++++ b/modules/installed/lib/auth.py
+@@ -12,6 +12,7 @@ import cherrypy
+ import urllib, hashlib
+ import cfg
+ import random
++import time
+
+ cfg.session_key = '_cp_username'
+
diff --git a/debian/patches/nodendor b/debian/patches/nodendor
new file mode 100644
index 0000000..c7986a1
--- /dev/null
+++ b/debian/patches/nodendor
@@ -0,0 +1,37 @@
+Author: Tzafrir Cohen <tzafrir@debian.org>
+Description: "vendor" packages are installed as separate system debs
+
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@ EXCLUDE=--exclude=*.tar.gz --exclude=*~
+ ALL_BUT_GZ=$(subst $(wildcard *.tar.gz),,$(wildcard *))
+
+ ## Catch-all tagets
+-default: predepend config dirs template css docs dbs
++default: config dirs template css docs dbs
+ all: default
+
+ predepend:
+--- a/plinth.py
++++ b/plinth.py
+@@ -17,8 +17,8 @@ import util as u
+ from logger import Logger
+ #from modules.auth import AuthController, require, member_of, name_is
+
+-from vendor.withsqlite.withsqlite import sqlite_db
+-from vendor.exmachina.exmachina import ExMachinaClient
++from withsqlite.withsqlite import sqlite_db
++from exmachina.exmachina import ExMachinaClient
+ import socket
+
+ __version__ = "0.2.14"
+--- a/start.sh
++++ b/start.sh
+@@ -5,6 +5,6 @@
+ export PYTHONPATH
+
+ sudo killall exmachina.py
+-sudo vendor/exmachina/exmachina.py -v &
++sudo /usr/share/pyshared/exmachina/exmachina.py -v &
+ python plinth.py
+ sudo killall exmachina.py
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ea163ff
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+nodendor
+debpathes
+import_time