summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAlex Landau <alex.landau@xorcom.com>2008-12-28 10:35:13 +0000
committerAlex Landau <alex.landau@xorcom.com>2008-12-28 10:35:13 +0000
commit9e0becb8a54c76aaaaea805fbb361d86f9ef90f6 (patch)
tree8c21f6c8a3d7b571368dcdd09c101ce33cd5f9f9 /debian
parent94e268f4d359d6d2de417f991b8ea6f420d60d58 (diff)
rapid-tunneling:
- .deb builds git-svn-id: svn+ssh://xorcom/home/svn/debs/components/rapid-tunneling@6501 283159da-0705-0410-b60c-f2062b4bb6ad
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/copyright10
-rw-r--r--debian/postinst4
-rw-r--r--debian/prerm2
-rw-r--r--debian/rapid-tunneling-server.install4
-rw-r--r--debian/rapid-tunneling-server.postinst45
-rw-r--r--debian/rapid-tunneling-server.prerm41
-rw-r--r--debian/rapid-tunneling.install4
8 files changed, 101 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 31b2930..1eaa77c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
-rapid-tunneling (1.0-1) unstable; urgency=low
+rapid-tunneling (1.01) unstable; urgency=low
- * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+ * Initial release
-- Alex Landau <alex.landau@xorcom.com> Sun, 14 Dec 2008 17:20:04 +0200
diff --git a/debian/copyright b/debian/copyright
index 58250d1..9053f8e 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,9 +1,7 @@
-This package was debianized by Alex Landau <alex@unknown> on
+This package was debianized by Alex Landau <alex.landau@xorcom.com> on
Sun, 14 Dec 2008 17:20:04 +0200.
-It was downloaded from <url://example.com>
-
-Upstream Author(s):
+Upstream Author:
Alex Landau <alex.landau@xorcom.com>
@@ -32,7 +30,3 @@ Public License can be found in `/usr/share/common-licenses/GPL'.
The Debian packaging is (C) 2008, Alex Landau <alex.landau@xorcom.com> and
is licensed under the GPL, see above.
-
-
-# Please also look if there are files or directories which have a
-# different copyright/license attached and list them here.
diff --git a/debian/postinst b/debian/postinst
index 25fde56..5fdc023 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -20,8 +20,8 @@ set -e
case "$1" in
configure)
- # add a user with uid=gid=0
- useradd -d /var/lib/rapid-tunneling/home -m -u 0 -g 0 -o rapid-tunneling 2>/dev/null || true
+ # add a user with uid=gid=0
+ useradd -d /var/lib/rapid-tunneling/home -m -u 0 -g 0 -o rapid-tunneling 2>/dev/null || true
;;
abort-upgrade|abort-remove|abort-deconfigure)
diff --git a/debian/prerm b/debian/prerm
index 7602eac..6eb5232 100644
--- a/debian/prerm
+++ b/debian/prerm
@@ -19,7 +19,7 @@ set -e
case "$1" in
remove)
- userdel -r rapid-tunneling || :
+ userdel -r rapid-tunneling || :
;;
failed-upgrade)
diff --git a/debian/rapid-tunneling-server.install b/debian/rapid-tunneling-server.install
new file mode 100644
index 0000000..035481c
--- /dev/null
+++ b/debian/rapid-tunneling-server.install
@@ -0,0 +1,4 @@
+etc/default/rtadm
+etc/ssh/sshd_support_config
+usr/sbin/rtadm
+usr/sbin/rt-from-remote
diff --git a/debian/rapid-tunneling-server.postinst b/debian/rapid-tunneling-server.postinst
new file mode 100644
index 0000000..a5a3541
--- /dev/null
+++ b/debian/rapid-tunneling-server.postinst
@@ -0,0 +1,45 @@
+#!/bin/sh
+# postinst script for rapid-tunneling-server
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ useradd -d /var/lib/rapid-tunneling-server -m support 2>/dev/null || :
+ LINE='export PATH=$PATH:/usr/sbin'
+ PROFILE=/var/lib/rapid-tunneling-server/.bash_profile
+ if ! fgrep -q "$LINE" $PROFILE; then echo "$LINE" >> $PROFILE; fi
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/rapid-tunneling-server.prerm b/debian/rapid-tunneling-server.prerm
new file mode 100644
index 0000000..c0c1ee2
--- /dev/null
+++ b/debian/rapid-tunneling-server.prerm
@@ -0,0 +1,41 @@
+#!/bin/sh
+# prerm script for rapid-tunneling
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <prerm> `remove'
+# * <old-prerm> `upgrade' <new-version>
+# * <new-prerm> `failed-upgrade' <old-version>
+# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
+# * <deconfigured's-prerm> `deconfigure' `in-favour'
+# <package-being-installed> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ remove)
+ userdel support || :
+ ;;
+
+ failed-upgrade)
+ ;;
+
+ *)
+ echo "prerm called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/rapid-tunneling.install b/debian/rapid-tunneling.install
new file mode 100644
index 0000000..9afcc19
--- /dev/null
+++ b/debian/rapid-tunneling.install
@@ -0,0 +1,4 @@
+usr/sbin/rapid-tunneling
+usr/sbin/rapid-tunneling-status
+var/lib/rapid-tunneling
+