summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-02-07 20:01:41 +0000
committerfile <file@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-02-07 20:01:41 +0000
commit003f15b10e12549e5367cec6655e092d9e536ccd (patch)
treec4f272c60b2acd813af4d9d5ec0294e1c0d0f5a3 /configure.ac
parent56047c008ff064912467cced28c178b2377bb48f (diff)
Merge in zaptel-firmware branch. This basically downloads the firmware from the FTP site and builds the appropriate headers based on the current version. Drivers just know they need a certain firmware and get fed the current version. If this prevents your zaptel from building do a make distclean and start fresh or make sure the firmware is checked in make menuselect.
git-svn-id: http://svn.digium.com/svn/zaptel/branches/1.4@2107 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 522b8f6..f2b916e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,15 @@ AC_PATH_PROG([GREP], [grep], :)
AC_PATH_PROG([SHELL], [sh], :)
AC_PATH_PROG([LN], [ln], :)
+AC_PATH_PROG([WGET], [wget], :)
+if test "${WGET}" != ":" ; then
+ DOWNLOAD=${WGET}
+else
+ AC_PATH_PROG([FETCH], [fetch], [:])
+ DOWNLOAD=${FETCH}
+fi
+AC_SUBST(DOWNLOAD)
+
AC_LANG(C)
AST_EXT_LIB([curses], [initscr], [curses.h], [CURSES], [curses], [])