summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortzafrir <tzafrir@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-09-08 12:08:48 +0000
committertzafrir <tzafrir@5390a7c7-147a-4af0-8ec9-7488f05a26cb>2007-09-08 12:08:48 +0000
commit4b735176f3e88b794b44d2b6c75c75cbc2b73b1c (patch)
tree211f0d6f83f082f46c635e28a46852ff6c2c0668 /configure.ac
parent0f037adc226298d4936c13e810919aa31aa665ed (diff)
* Let autoconf figure out the switches for asciidoc.
* Remove some leftover set -x from previous debug... git-svn-id: http://svn.digium.com/svn/zaptel/branches/1.4@2999 5390a7c7-147a-4af0-8ec9-7488f05a26cb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2fe6069..7f05619 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,12 +60,19 @@ AST_EXT_LIB([ncurses], [initscr], [curses.h], [NCURSES], [ncurses], [])
AST_EXT_LIB([newt], [newtBell], [newt.h], [NEWT], [newt])
AST_EXT_LIB([usb], [usb_init], [usb.h], [USB], [libusb])
+# for asciidoc before ver. 7, the backend must be stated explicitly:
+ASCIIDOC='asciidoc'
+asciidoc_ver=`asciidoc --version 2>&1 | awk '/^asciidoc /{print $2}' | cut -d. -f 1 | head -n 1`
+if test "$asciidoc_ver" != '' && test $asciidoc_ver -lt 7; then
+ ASCIIDOC="asciidoc -b xhtml"
+fi
+AC_SUBST(ASCIIDOC)
+
AC_ARG_WITH(ppp,
[AS_HELP_STRING([--with-ppp=PATH],[Use ppp support from PATH])],
[],
[with_ppp=check]
)
-set -x
# somebody will fix that
default_ppp_path=/usr
@@ -91,7 +98,7 @@ case "$with_ppp" in
fi
;;
esac
-set +x
+
AC_SUBST(PPPD_VERSION)
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts])